Bug 1267656 - Smartcard login when certificate on the card is revoked and ocsp check enabled is not supported
Summary: Smartcard login when certificate on the card is revoked and ocsp check enable...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On: 1362688
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-30 15:15 UTC by Roshni
Modified: 2020-05-02 18:11 UTC (History)
12 users (show)

Fixed In Version: sssd-1.14.0-0.1.alpha.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:11:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 3853 None None None 2020-05-02 18:11:41 UTC
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Roshni 2015-09-30 15:15:20 UTC
Description of problem:
Smartcard login when certificate on the card is revoked and ocsp check enabled is not supported

Version-Release number of selected component (if applicable):
ipa-client-4.2.0-12.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Setup ipa environment for smartcard login
2. Create an ipa user to be used for smartcard login
3. Enroll a smartcard with certificate issued by non-ipa CA (the certificate on the smartcard should have the ocsp url)
4. assign the cert on the smartcard to the ipa user
5. Revoke the certificate on smartcard on the non-IPA CA
6. Login using smartcard


Actual results:
Smartcard login should fail, ocsp check should be enabled by default

Expected results:
smartcard login is successful

Additional info:

Comment 2 Jakub Hrozek 2015-10-01 12:22:03 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2812

Comment 3 Jakub Hrozek 2015-11-26 15:49:07 UTC
Fixed upstream:
    master: 544a20de7667f05c1a406c4dea0706b0ab507430
    sssd-1-13: 14a983160300421b048b9665114b909c42684cec

Comment 4 Mike McCune 2016-03-28 23:36:13 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Roshni 2016-08-31 13:43:56 UTC
[root@dhcp129-53 ~]# rpm -qi sssd
Name        : sssd
Version     : 1.14.0
Release     : 27.el7
Architecture: x86_64
Install Date: Mon 29 Aug 2016 03:11:03 PM EDT
Group       : Applications/System
Size        : 35147
License     : GPLv3+
Signature   : RSA/SHA256, Tue 23 Aug 2016 09:39:09 AM EDT, Key ID 938a80caf21541eb
Source RPM  : sssd-1.14.0-27.el7.src.rpm
Build Date  : Fri 19 Aug 2016 06:43:40 AM EDT
Build Host  : x86-037.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon

Verification steps as explained in comment 0. Login was not successful when the certificate on the smartcard was in revoked state.

Comment 8 errata-xmlrpc 2016-11-04 07:11:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.