Bug 1267692 - Host clone should include associated Puppet classes
Host clone should include associated Puppet classes
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.4
: --
Assigned To: Christine Fouant
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 13:11 EDT by Christine Fouant
Modified: 2017-02-23 14:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 10:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 8521 None None None 2016-04-22 12:58 EDT

  None (edit)
Description Christine Fouant 2015-09-30 13:11:57 EDT
As of @1.6.3@, cloning a host does not duplicate it's included classes.  It would be very convient when provisioning multiple hosts if there was a mechanism to clone an existing host that encompassed config groups, included classes, and host level parameters.
Comment 1 Christine Fouant 2015-09-30 13:11:59 EDT
Created from redmine issue http://projects.theforeman.org/issues/8521
Comment 5 jcallaha 2015-11-04 13:44:30 EST
Verified. Puppet classes are now included in cloned host groups.

  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.7.2
SATELLITE: 6.1.4
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.6.2
Comment 9 errata-xmlrpc 2015-11-19 10:57:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2474

Note You need to log in before you can comment on or make changes to this bug.