Bug 1267693 - Cloning of hostgroup redirects to host creation
Cloning of hostgroup redirects to host creation
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.4
: --
Assigned To: Marek Hulan
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 13:12 EDT by Christine Fouant
Modified: 2017-02-23 14:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 10:57:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11761 None None None 2016-04-22 12:25 EDT

  None (edit)
Description Christine Fouant 2015-09-30 13:12:52 EDT
After #11683 was merged, hostgroup can no longer be cloned. When I submit the form with new attributes, the form is redirected to host creation action. The patch "added data-submit":https://github.com/theforeman/foreman/pull/2677/files#diff-db336c69095130c90178c09661f8e4cfR2 to the form but it does not seem to be "supported":https://github.com/theforeman/foreman/blob/88275be4587e98092095c501a8a7f58d7bcfaca4/app/assets/javascripts/host_edit.js#L485 for anything else than hosts
Comment 1 Christine Fouant 2015-09-30 13:12:54 EDT
Created from redmine issue http://projects.theforeman.org/issues/11761
Comment 5 jcallaha 2015-11-04 13:46:19 EST
Verified. Clone button leads to the cloned host group page where the user is prompted to enter a name (among other options).

  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.7.2
SATELLITE: 6.1.4
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.6.2
Comment 9 errata-xmlrpc 2015-11-19 10:57:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2474

Note You need to log in before you can comment on or make changes to this bug.