Bug 1267707 - systemd-logind __epoll_wait_nocancel crash
systemd-logind __epoll_wait_nocancel crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
x86_64 Linux
high Severity high
: rc
: 7.3
Assigned To: Jan Synacek
Branislav Blaškovič
Lucie Maňásková
:
Depends On:
Blocks: 1203710
  Show dependency treegraph
 
Reported: 2015-09-30 14:19 EDT by Scott Poore
Modified: 2016-11-03 20:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: systemd-219-25.el7
Doc Type: Release Note
Doc Text:
The value of "net.unix.max_dgram_qlen" increased to 512 Previously, the default value of the "net.unix.max_dgram_qlen" kernel option was 16. As a consequence, when the network traffic was too high, certain services could terminate unexpectedly. This update sets the value to 512, thus preventing this problem. Users need to reboot the machine to apply this change.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:44:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt email (21.72 KB, text/plain)
2015-09-30 14:22 EDT, Scott Poore
no flags Details

  None (edit)
Description Scott Poore 2015-09-30 14:19:42 EDT
Description of problem:

Received abrt report on crash:

time:           Wed 30 Sep 2015 11:31:49 AM EDT
cmdline:        /usr/lib/systemd/systemd-logind
uid:            0 (root)
abrt_version:   2.1.11
backtrace_rating: 4
crash_function: __epoll_wait_nocancel
event_log:      
executable:     /usr/lib/systemd/systemd-logind
global_pid:     621
hostname:       ibm-hs21-12.testrelm.test
kernel:         3.10.0-320.el7.x86_64
last_occurrence: 1443627109
pid:            621
pkg_arch:       x86_64
pkg_epoch:      0
pkg_name:       systemd
pkg_release:    17.el7
pkg_version:    219
pwd:            /
runlevel:       N 3
username:       root

coredump.gz:    Binary file, 71736 bytes

Version-Release number of selected component (if applicable):
pkg_name:       systemd
pkg_release:    17.el7
pkg_version:    219

How reproducible:
unknown

Steps to Reproduce:
Unknown

Actual results:
crash

Expected results:
no crash

Additional info:
Comment 1 Scott Poore 2015-09-30 14:22 EDT
Created attachment 1078763 [details]
abrt email
Comment 3 masanari iida 2016-03-02 23:55:02 EST
Same crash 
OS RHEL7.1 + Update systemd, dracut, linux-firmware and kernel.

systemd-219-19.el7.x86_64

(gdb) bt
#0  0x00007fa408d77763 in __epoll_wait_nocancel () from /lib64/libc.so.6
#1  0x00007fa409ce3449 in sd_event_wait (e=e@entry=0x7fa40a4b1230,
    timeout=timeout@entry=18446744073709551615)
    at src/libsystemd/sd-event/sd-event.c:2372
#2  0x00007fa409cda137 in sd_event_run (timeout=18446744073709551615,
    e=0x7fa40a4b1230) at src/libsystemd/sd-event/sd-event.c:2499
#3  manager_run (m=0x7fa40a4b00a0) at src/login/logind.c:1119
#4  main (argc=<optimized out>, argv=<optimized out>)
    at src/login/logind.c:1181
Comment 6 Michal Sekletar 2016-06-27 12:21:00 EDT
We should definitely backport commit that adjusts watchdog timeout. 1min. is just too short in some cases. Also there are couple other related fixes we should pull in

https://github.com/systemd/systemd/commit/19854865a877a3a4fa3d04550c15a99c0e1187ff
https://github.com/systemd/systemd/commit/b215b0ede11c0dda90009c8412609d2416150075
Comment 7 Jan Synacek 2016-07-13 08:07:10 EDT
https://github.com/lnykryn/systemd-rhel/pull/36
Comment 8 Branislav Blaškovič 2016-07-18 03:26:00 EDT
QA acking..
Comment 13 errata-xmlrpc 2016-11-03 20:44:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html

Note You need to log in before you can comment on or make changes to this bug.