Bug 126772 - M-x telnet in emacs (and xemacs) locks up system temporarily
M-x telnet in emacs (and xemacs) locks up system temporarily
Status: CLOSED DUPLICATE of bug 128154
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-26 07:33 EDT by Benny Amorsen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benny Amorsen 2004-06-26 07:33:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
Emacs causes a lockup of X when M-x telnet is used. The mouse pointer
gets jerky and eventually stops. The keyboard stops responding, even
to Num Lock. After a while (say, half a minute) the system recovers.
Load avg goes up to 15 or so, and CPU stays at 100% for the duration.
With xemacs the load spike is there as well, but the system doesn't
stop completely.



Version-Release number of selected component (if applicable):
emacs-21.3-14

How reproducible:
Always

Steps to Reproduce:
1. Start emacs
2. M-x telnet sunsite.dk 80
3.
    

Actual Results:  The load avg goes to 15 and X becomes unresponsive

Expected Results:  telnet should have connected to port 80 on sunsite.dk

Additional info:

This may or may not be related to pty handling, as strace shows a lot
of these:

29048 12:54:23 open("/dev/ptye5", O_RDWR) = -1 ENXIO (No such device
or address)
29048 12:54:23 --- SIGALRM (Alarm clock) @ 0 (0) ---
29048 12:54:23 gettimeofday({1088247263, 401741}, NULL) = 0
29048 12:54:23 gettimeofday({1088247263, 402017}, NULL) = 0
29048 12:54:23 gettimeofday({1088247263, 402271}, NULL) = 0
29048 12:54:23 setitimer(ITIMER_REAL, {it_interval={0, 0},
it_value={0, 99470}}, NULL) = 0
29048 12:54:23 sigreturn()              = ? (mask now [])
Comment 1 Benny Amorsen 2004-06-26 12:55:46 EDT
The problem was reported with kernel-2.6.7-1.441.

It seems to be gone with kernel-2.6.7-1.456. At least it is not
reproducible after reboot into that kernel.
Comment 2 Benny Amorsen 2004-06-27 08:44:31 EDT
It's a heisenbug! It is back now with a vengeance, still on kernel
2.6.7-1.456. No configuration changes or anything that can explain it.
I hope it can be reproduced by someone else.
Comment 3 Jens Petersen 2004-08-05 03:16:51 EDT
Can you describe your environment in more detail?
Is this with a fresh rawhide install?

I don't see this in FC2 for example, do you?
Comment 4 Benny Amorsen 2004-08-05 07:45:13 EDT
This problem is a dupe of 128154. Well technically 128154 is a dupe of
this problem, but 128154 has better discussion going on.
Comment 5 Jens Petersen 2004-08-05 09:14:52 EDT

*** This bug has been marked as a duplicate of 128154 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:04:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.