This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126773 - KDE Keyboard Language switching broken
KDE Keyboard Language switching broken
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kde-i18n (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-26 07:41 EDT by Gerard Fernandes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 05:55:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2004-06-26 07:41:19 EDT
Description of problem: Installed "Workstation" with KDE. Installed 2
languages - English (default) and Portuguese (additional).
Am able to switch languages in GNOME through the switch keyboard
applet - however GNOME is very unusable because it applies keyboard
layout PER WINDOW and therefore requires a restart of the Application
before the keyboard switch is effective.

KDE (in FC-1) could easily switch with one click on the Keyboard
Layout Switcher Panel applet.

KDE (in FC-2) does not show additional languages in the Keyboard
Preferences applet.


Version-Release number of selected component (if applicable):
KDE 3.2.2

How reproducible:
Always

Steps to Reproduce:
1. Install typical "Workstation" from FC-2 DVD
2. In customise packages, select KDE
3. Select English as default and add Portuguese as additional Language.
4. Install
5. Log in as a normal User into KDE
6. Go to the KDE control center
7. Go to Keyboard configuration
8. Enable multiple Keyboard Layouts
7. Attempt to add multiple keyboard layouts - No options displayed.
  
Actual results:
A list of available Keyboard Layouts should be displayed


Expected results:
On selection of available layouts, switching should be possible with
the Keyboard Layout switching applet.


Additional info:
Comment 1 Ngo Than 2004-06-28 05:55:29 EDT
it'a a know bug and is fixed in kde-3.2.3, which you can download from
ftp.kde.org for FC2. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.