Bug 1267743 - bind mounting /dev does not mount devpts
bind mounting /dev does not mount devpts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 16:20 EDT by Brent Baude
Modified: 2015-11-17 17:54 EST (History)
2 users (show)

See Also:
Fixed In Version: docker-1.8.2-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1267975 (view as bug list)
Environment:
Last Closed: 2015-11-17 17:54:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Baude 2015-09-30 16:20:24 EDT
With current docker versions, when you bind mount /dev from the host to /dev in the container (i.e. -v/dev:/dev), it does not also mount devpts.  Therefore, the host becomes unusable because the virtual ptys are no longer able to start.  This is a critical bug.

These patches remedy this bug:

  * https://github.com/docker/docker/pull/16639
  * https://github.com/opencontainers/runc/commit/c9d58506297ed6c86c9d8a91d861e4de3772e699

Lokesh built a scratch build and we confirmed the problem is corrected.
Comment 2 Lokesh Mandvekar 2015-11-17 17:54:07 EST
This version has been shipped already.

Note You need to log in before you can comment on or make changes to this bug.