Bug 1267756 - Audio is broken on Dell XPS 13 as of Linux 4.2+
Audio is broken on Dell XPS 13 as of Linux 4.2+
Status: CLOSED DUPLICATE of bug 1255070
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 17:26 EDT by Mykola Dvornik
Modified: 2015-10-01 14:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 11:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Dvornik 2015-09-30 17:26:40 EDT
Description of problem:

As of Linux 4.2+ the supported ACPI revision reported back to BIOS is set statically to '2' to match Windows behaviour. This breaks audio on Dell XPS 13 , since BIOS forces ASoC to operate in I2S mode that even Linux 4.3 does not support properly yet.

There is a work around that allows the reported ACPI revision to be forced via kernel parameter http://mailman.alsa-project.org/pipermail/alsa-devel/2015-May/092051.html.

So it would be nice to have 

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y 

added to the Linux 4.2+ builds
 

Version-Release number of selected component (if applicable):

Linux 4.2+

How reproducible:

Persistent

Steps to Reproduce:
1. Operate FC23 using 4.1.x kernel and make sure that ASoC is in HDA mode.
2. Update kernel to 4.2+.

Actual results:

Audio is broken, i.e. only built-in speakers work. No MIC, crappy sound out of the headphone output. Toggling things in alasmixer doesn't help much.

Expected results:

Fully working audio system.

Additional info:
Comment 1 Justin M. Forbes 2015-10-01 11:17:06 EDT
The proper solution here is to update your firmware to revision A05 or newer, this makes the ACPI override unneccesary.
Comment 2 Mykola Dvornik 2015-10-01 14:23:13 EDT

*** This bug has been marked as a duplicate of bug 1255070 ***

Note You need to log in before you can comment on or make changes to this bug.