This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267758 - RHEV Validation failed: error, wrong number of arguments (2 for 0)
RHEV Validation failed: error, wrong number of arguments (2 for 0)
Status: CLOSED DUPLICATE of bug 1265466
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
rhev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 17:33 EDT by Nandini Chandra
Modified: 2016-01-07 10:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 13:35:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-09-30 17:33:20 EDT
Description of problem:
------------------------
After validating a RHEV provider against default credentials,I tried validating the provider against the C&U creds.The C&U credential validation was successful.
But the summary page shows the status of 'Default Credentials' as 'Error'.The status was valid until the C&U creds were added.

evm.log:

[----] E, [2015-09-30T17:12:04.349857 #2851:f71994] ERROR -- : <RHEVM> Ovirt::Service#resource_get: class = ArgumentError, message=wrong number of arguments (2 for 0), URI=https://xx:yy.zz.ww:443/api
[----] W, [2015-09-30T17:12:04.350393 #2851:f71994]  WARN -- : MIQ(ManageIQ::Providers::Redhat::InfraManager#authentication_check_no_validation) type: [:default] for [1000000000005] [rhevm3.4] Validation failed: error, wrong number of arguments (2 for 0)
[----] W, [2015-09-30T17:12:04.350981 #2851:f71994]  WARN -- : MIQ(AuthUseridPassword#validation_failed) [ExtManagementSystem] [1000000000005], previously valid on: 2015-09-30 21:02:52 UTC, previous status: [Valid]


Version-Release number of selected component (if applicable):
---------------------
5.5.0.2


How reproducible:
-----------------
Sometimes


Steps to Reproduce:
-------------------
1.
2.
3.


Actual results:
----------------


Expected results:
-----------------


Additional info:
---------------
I see this issue while validating C&U creds for both RHEV 3.4 and RHEV 3.5.
Comment 3 Nandini Chandra 2015-09-30 17:37:41 EDT
I have marked this as high since this issue is blocking QE from testing C&U collection from RHEV providers on CFME 5.5.
Comment 5 Dave Johnson 2015-11-16 12:42:20 EST
confirmed with Nandini, not a blocker, comment 3 is in error and should be ignored
Comment 6 Nandini Chandra 2015-11-16 12:46:52 EST
Prior to 5.5.0.8,I wasn't able to collect C&U data from RHEVM providers.

https://bugzilla.redhat.com/show_bug.cgi?id=1265466 was fixed in 5.5.0.8,
so maybe this is related to that.
Comment 7 Nandini Chandra 2015-11-17 13:35:22 EST
I don't see this issue in builds >= 5.5.0.8,so closing it as a clone of BZ 1265466.

*** This bug has been marked as a duplicate of bug 1265466 ***
Comment 8 Nandini Chandra 2015-11-19 15:37:50 EST
Comment # 7 should read 

I don't see this issue in builds >= 5.5.0.8,so closing it as a duplicate of BZ 1265466.

Note You need to log in before you can comment on or make changes to this bug.