Bug 1267827 - RHEL7.2:Samba:Yum update does not update to the latest rhgs-samba package when rhel7.2 repo is used which has higher samba version
RHEL7.2:Samba:Yum update does not update to the latest rhgs-samba package whe...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: rhs-smb@redhat.com
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 03:42 EDT by surabhi
Modified: 2015-11-19 07:55 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, during the upgrade of the underlying Red Hat Enterprise Linux operating system to version 7.2, the version of Samba installed with Red Hat Gluster Storage would be replaced by the newer Samba version of Red Hat Enterprise Linux. As a consequence, the SMB features of the Red Hat Gluster Storage installation would stop working. With this update, the Samba version of RHGS is updated so that it will no longer be overwritten by the Red Hat Enterprise Linux update. The updated Samba package also complies with new dependencies of other Red Hat Enterprise Linux 7.2 packages. This update must be installed either prior to or along with the Red Hat Enterprise Linux update. This ensures continued functionality of the SMB features of the Red Hat Gluster Storage installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:55:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2015-10-01 03:42:13 EDT
Description of problem:
When samba packages are already installed in RHEL7.2, after adding latest rhgs and rhgs-samba channels, the rhgs-samba packages doesn't get upgraded.

In a layered install it fails to update the latest samba package.

Version-Release number of selected component (if applicable):
RHEL7.2 : 
Samba version:samba-4.2.3-5.el7.x86_64
RHS-samba version: 
samba-4.1.17-14.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL7.2 ISO 
2.Subscribe to rhel base channel and yum update
3.Add the ISO repo to get the latest packages for 7.2 , yum update
4. Yum install samba 
5. Subscribe to rhgs channel and rhgs-samba channel
6. Do yum update

Actual results:
The samba packages from rhgs channels doesn't get updated to the latest one.


Expected results:

The samba packages from rhgs-channel should get updated for rhgs customers.


Additional info:
Need a way to resolve the conflict so the rhgs samba packages gets updated with yum update on RHEL7.2
Comment 2 Guenther Deschner 2015-10-16 05:44:09 EDT
samba-4.2.4-3.el6rhs and samba-4.2.4-3.el7rhgs should have this addressed.
Comment 8 surabhi 2015-11-13 06:16:06 EST
On RHEL7.1 with installed samba packages, adding RHEL7.2 repo and rhgs-samba repo and doing yum update updates the samba version successfully from RHGS-samba channel and there are no conflicts seen with RHEl samba packages.
Marking the BZ verified.
Comment 14 errata-xmlrpc 2015-11-19 07:55:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2467.html

Note You need to log in before you can comment on or make changes to this bug.