Bug 1267848 - [New] - Running Configure-gluster-nagios command fails with error 'restore_sigpipe' on RHEL7.2 nodes
[New] - Running Configure-gluster-nagios command fails with error 'restore_s...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Ramesh N
RHS-C QE
: ZStream
Depends On: 1117751
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-10-01 04:41 EDT by RamaKasturi
Modified: 2016-03-01 01:12 EST (History)
6 users (show)

See Also:
Fixed In Version: python-2.7.5-34.el7.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:12:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-10-01 04:41:09 EDT
Description of problem:
When user tries to run configure-gluster-nagios command on RHEL7.2 nodes where nagios is installed, it throws out the following error.
[root@dhcp37-54 ~]# configure-gluster-nagios -c cluster1 -H dhcp37-54.lab.eng.blr.redhat.com
Traceback (most recent call last):
  File "/usr/bin/configure-gluster-nagios", line 541, in <module>
    clusterdata = discoverCluster(args.hostip, args.cluster, args.timeout)
  File "/usr/bin/configure-gluster-nagios", line 90, in discoverCluster
    componentlist = discoverVolumes(hostip, timeout)
  File "/usr/bin/configure-gluster-nagios", line 53, in discoverVolumes
    timeout=timeout)
  File "/usr/lib64/nagios/plugins/gluster/server_utils.py", line 114, in execNRPECommand
    (returncode, outputStr, err) = utils.execCmd(nrpeCmd, raw=True)
  File "/usr/lib64/python2.7/site-packages/glusternagios/utils.py", line 403, in execCmd
    deathSignal=deathSignal, childUmask=childUmask)
  File "/usr/lib64/python2.7/site-packages/cpopen/__init__.py", line 51, in __init__
    stderr=PIPE)
  File "/usr/lib64/python2.7/subprocess.py", line 712, in __init__
    restore_sigpipe=restore_sigpipe)
TypeError: _execute_child_v276() got an unexpected keyword argument 'restore_sigpipe'

Version-Release number of selected component (if applicable):
nagios-server-addons-0.2.2-1.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install two RHEL7.2 machines
2. Subscribe to all RHGS and nagios channels
3. Run 'yum install redhat-storage-server' on all the nodes in the cluster.
4. Install nagios on one of the node in the cluster by running the command 'yum install nagios-server-addons'
5. Run the command 'configure-gluster-nagios' to start monitor the nodes.

Actual results:
configure-gluster-nagios command fails with restore_sigpipe  error.

Expected results:
configure-gluster-nagios should run successfully with out any error

Additional info:
Comment 3 RamaKasturi 2015-10-07 04:46:05 EDT
Hi,

   I have installed the latest compose which is mentioned in comment 2 and i still see the issue reported. Following are my observations:

I tried doing a layered install of redhat-storage-server and while the installation is going i see trace back errors on the stdout:

http://pastebin.test.redhat.com/317957

Following is the python version :

[root@dhcp37-83 rhn]# rpm -qa | grep python-2.7.5-33.el7
python-2.7.5-33.el7.x86_64

Running configure-gluster-nagios or adding the node to console gives the same issue which is reported above.

Thanks
kasturi.
Comment 8 Ramesh N 2015-10-30 05:20:02 EDT
Issue is fixed in python version python-2.7.5-34.el7.x86_64 which is now part of RHEL 7.2 issue. Moving the bug to ON_QA.
Comment 9 RamaKasturi 2015-10-30 06:16:01 EDT
Verified and works fine with python version python-2.7.5-34.el7.x86_64.

The above python version is included in the compose http://download.eng.bos.redhat.com/rel-eng/RHEL-7.2-Snapshot-5.0/compose/Server/x86_64/iso/ and tested with this compose as well.

Marking it verified.
Comment 13 errata-xmlrpc 2016-03-01 01:12:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.