Bug 1267851 - automated CI checks no longer work in the ovirt-3.5 branch
automated CI checks no longer work in the ovirt-3.5 branch
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.16.27
Unspecified Unspecified
high Severity low (vote)
: ovirt-3.5.6
: 4.16.28
Assigned To: Francesco Romani
Pavel Stehlik
infra
: CodeChange
Depends On:
Blocks: 1268229
  Show dependency treegraph
 
Reported: 2015-10-01 04:44 EDT by Francesco Romani
Modified: 2016-02-10 14:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1268229 (view as bug list)
Environment:
Last Closed: 2015-12-22 08:24:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.5.z+
mgoldboi: planning_ack+
danken: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 39948 ovirt-3.5 MERGED tests: clear libvirtconnection cache Never
oVirt gerrit 39949 ovirt-3.5 MERGED tests: disable memoization in testrunner Never
oVirt gerrit 40029 ovirt-3.5 MERGED utils: Add memoized invalidation Never
oVirt gerrit 40030 ovirt-3.5 MERGED tests: Enable again utils.memoized in the tests Never
oVirt gerrit 46883 ovirt-3.5 MERGED Adding check-patch ci script Never
oVirt gerrit 46884 ovirt-3.5 ABANDONED tests: temporarily exclude few tests to restore CI Never
oVirt gerrit 46885 ovirt-3.5 MERGED automation: enable pep8 Never
oVirt gerrit 46886 ovirt-3.5 MERGED automation: add build_artifacts Never
oVirt gerrit 47013 ovirt-3.5 MERGED takset: fix taskset and tests on python 2.6 Never
oVirt gerrit 47038 ovirt-3.5 MERGED tests: Fix unmount in mkimage tests Never
oVirt gerrit 47039 ovirt-3.5 MERGED utils: Add stopwatch for timing operations Never
oVirt gerrit 47040 ovirt-3.5 MERGED tests: Wait for udev events after unmounting Never
oVirt gerrit 47047 ovirt-3.5 MERGED pep8: fix complaints Never
oVirt gerrit 47326 ovirt-3.5 MERGED tests: Fix and simplify cleanup after failures Never
oVirt gerrit 47554 ovirt-3.5 ABANDONED spec: fix requirement version Never
oVirt gerrit 47731 ovirt-3.5 MERGED automation: Disable tests requiring tun device Never

  None (edit)
Description Francesco Romani 2015-10-01 04:44:39 EDT
Description of problem:
We need to backport the automation scripts to the ovirt-3.5 stable branch.
This is safe -no code change involved at all-, and we can reuse all the work done on more modern branches.

This bug is to track this operation


Version-Release number of selected component (if applicable):
4.16.27

How reproducible:
100%

Steps to Reproduce:
1. submit a patch to gerrit, targeting ovirt-3.5 branch

Actual results:
No automated CI sanity checks and tests run

Expected results:
Automated CI sanity checks and tests should run
Comment 1 Francesco Romani 2015-10-01 05:40:34 EDT
priority high, severity low: this doesn't directly impact any customer.
However, it greatly helps the maintainership effort
Comment 2 Oved Ourfali 2015-10-19 05:09:51 EDT
Francesco, why not targeting to ovirt-engine-3.5.6 (and not 3.5.7?)
Comment 3 Francesco Romani 2015-10-20 04:25:18 EDT
(In reply to Oved Ourfali from comment #2)
> Francesco, why not targeting to ovirt-engine-3.5.6 (and not 3.5.7?)

No reason, actually the earlier is in, the better. Changed.

Please note that there is no 4.16.x version available in "target release" dropdown menu, so I can't set it.
Comment 4 Oved Ourfali 2015-10-25 07:16:26 EDT
Will it be in on time (gonna be built on Tuesday)?
Comment 5 Francesco Romani 2015-10-26 06:38:29 EDT
(In reply to Oved Ourfali from comment #4)
> Will it be in on time (gonna be built on Tuesday)?

The status is better than it could look at first glance.

Most patches are on track and near to merge; quite some of them don't affect production code, because they are about either tests or automation scripts.

It seems we are stuck because the automation script complain about missing target releases for stable branch; this is in turn caused by the lack of suitable options in the "target release" drop down menu on BZ. We need to fill some future target releases (4.16.27...28...29...30...).
Comment 6 Francesco Romani 2015-10-27 04:07:08 EDT
all relevant patches merged -> MODIFIED.

We can enable the job on jenkisns side and see.
Comment 7 Gil Klein 2015-11-04 03:06:09 EST
Francesco, Does any QE verification needed on this?
Comment 8 Francesco Romani 2015-11-04 03:18:54 EST
(In reply to Gil Klein from comment #7)
> Francesco, Does any QE verification needed on this?

I'd say no. All the changes we backported are either on automation scripts (= no production code changed at all) or in the test code, which is exercised each time tests are runned. Can't think of any production code change.
Comment 9 Pavel Stehlik 2015-11-04 07:00:50 EST
(In reply to Francesco Romani from comment #8)
> (In reply to Gil Klein from comment #7)
> > Francesco, Does any QE verification needed on this?
> 
> I'd say no. All the changes we backported are either on automation scripts
> (= no production code changed at all) or in the test code, which is
> exercised each time tests are runned. Can't think of any production code
> change.

Thus CodeChange, P.
Comment 10 Sandro Bonazzola 2015-12-22 08:24:37 EST
oVirt 3.5.6 has been released and the bz verified, moving to closed current release.

Note You need to log in before you can comment on or make changes to this bug.