Bug 1267852 - [xbae] requires lesstif instead of motif
[xbae] requires lesstif instead of motif
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xbae (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 04:44 EDT by Joachim Frieben
Modified: 2015-10-07 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: xbae-4.60.4-21.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 03:49:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-10-01 04:44:55 EDT
Description of problem:
The official Motif library landed in the Fedora package repository three years ago. Unlike packages like dx, package xbae still depends on lesstif which is a broken, incomplete and abandoned implementation of Motif.

Version-Release number of selected component (if applicable):
xbae-4.60.4-20.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Install package xbae.

Actual results:
Package lesstif will be pulled in.

Expected results:
Package motif gets pulled in.

Additional info:
- A locally built package xbae depending on motif (actually, lesstif-(devel) has been replaced by motif-(devel) in the spec file) works as expected.
- Package lesstif should be removed from Fedora altogether since even its own developers urge users to move to Motif.
Comment 1 Fedora Update System 2015-10-01 08:56:11 EDT
xbae-4.60.4-21.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5842a553e8
Comment 2 Fedora Update System 2015-10-03 21:53:17 EDT
xbae-4.60.4-21.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xbae'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5842a553e8
Comment 3 Fedora Update System 2015-10-07 12:35:17 EDT
xbae-4.60.4-21.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.