Bug 1267866 - Tasklist loading times too long on many production databases (30seconds +)
Tasklist loading times too long on many production databases (30seconds +)
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 05:09 EDT by Jan Hrcek
Modified: 2015-10-14 08:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 08:34:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot illustrating the issue - loading animation in the table (41.97 KB, image/png)
2015-10-01 06:24 EDT, Jan Hrcek
no flags Details
server logs from test runs with 3 dbs with most fails (57.93 KB, application/zip)
2015-10-01 08:49 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2015-10-01 05:09:17 EDT
Description of problem:
Tasklist loading times too long on many production databases (30seconds +)

When business-central is deployed with production databases it often happens that tasklist loading times become unacceptable (more than 30 seconds) after some interaction with task list (creating & completing a few tasks / leaving / returning to task list perspective).

A large portion of selenium tasklist tests fails when waiting for some tasks to be loaded. The tests are waiting for the loading animation gif to disappear (see screenshot from one of the failed tests attached). I had to increase the wait timeout to 30 seconds, but many tests are still failing (== loading animation still doesn't disappear after 30 seconds).

Here's the scale of the problem:
Out of 38 selenium tests of task list the loading animation doesn't disappear within 30 seconds (thus causing the test to fail) in
	16 tests on Oracle12
	16 tests on DB2 10.5
	5 tests on Postgresql 9.3
	18 tests on MsSQL 2012
	2 tests on Sybase 15.7
	3 tests on Oracle11gR2
	4 tests on DB2 9.7
	8 tests on Postgresql Enterprise 9.3
	6 tests on Postgresql 8.4

These numbers are relatively stable across several test runs.

Version-Release number of selected component (if applicable):
6.3.x snapshot

How reproducible:
Often (it happens on average in 25% of tests, which I believe is enough to make this into blocker)

Steps to Reproduce:
not clear yet, Will post as soon as I have some more specific info

Actual results:
After entering task list, with Active filter active, the tasks are never (at least not within 30 seconds) loaded, loading animation displayed indefinitely.

Expected results:
From UX point of view, loading of tasks should not exceed more than few seconds in single user scenario.
Comment 1 Mauricio Salatino 2015-10-01 05:33:08 EDT
Hi Jan, 
can you please check the server logs to find if there is an error on the backend?
The queries should be paginated, so not more than X results should be returned each time. Unless the queries are taking forever, which it shouldn't I don't see the reason for the delay. 
Are you testing on local databases? or remote ones?
Comment 2 Jan Hrcek 2015-10-01 06:24 EDT
Created attachment 1079004 [details]
Screenshot illustrating the issue - loading animation in the table
Comment 3 Jan Hrcek 2015-10-01 07:23:21 EDT
The DB's used for testing are local to the testing machines in jenkins environment (both in middleware lab in Boston).
Didn't find anything related to this issue in server logs.
Still working on reproducer for this issue.
Comment 4 Jan Hrcek 2015-10-01 08:48:31 EDT
Still couldn't reproduce the issue, but I'm attaching server logs from the 3 DB's that have the most fails caused by this issue (more than 30% tests failing because of this). Could you please check the logs and see if you find anything suspicious in the meantime, while I'm trying to find a way to reproduce this manually?
Comment 5 Jan Hrcek 2015-10-01 08:49 EDT
Created attachment 1079092 [details]
server logs from test runs with 3 dbs with most fails
Comment 6 Mauricio Salatino 2015-10-01 11:00:43 EDT
I couldn't reproduce it.

I've just tested posgreSQL locally with 80 tasks and it was working perfectly fine. The loading time for the task list was less than a second. Sorting by all the columns took less than a second too.
Comment 7 Jan Hrcek 2015-10-09 04:42:09 EDT
I found out that this was mostly problem with selenium automation. I discovered slight inefficiency that caused that 'Active' tab was clicked twice in a row in rapid succession. This leads to multiple DataSetLookup requests being sent to server. I fixed this and most of the occurrences of this issue are gone (1-3 are still remaining however). Let's keep this open and see if it improves in the next build, where the logic to reduce number of dataset lookup requests was implemented.
Comment 8 Mauricio Salatino 2015-10-12 04:09:48 EDT
Jan, I've also found that issue of double clicking the first tab. We will need to investigate that one, because it seems to be related with the Tab Panels and not the task lists per se. So we might need another BZ to report only that? Because now the name of this BZ is really confusing and sounds really critical. 
Can we set this as Closed and have a new one explaining the remaining failures?
Comment 9 Jan Hrcek 2015-10-12 04:35:47 EDT
I'm ok with closing this one, but I need more details about the way you reproduced it. What DB did you use? In which of the perspectives did you reproduce it? Did you have a lot of data there? Let's discuss this on IRC.
Comment 10 Mauricio Salatino 2015-10-14 05:14:54 EDT
Hi Jan, 
I've tested it with PosgreSQL, but I didn't see any issue with it. I just found out that if you double click in the first tab twice it refreshes twice, something that doesn't happen with the other tabs. Can we please close this one, because it is marked as urgent, but the refresh of the first tab shouldn't be a big issue, and we can investigate it after the release.
Comment 11 Jan Hrcek 2015-10-14 08:34:12 EDT
Ok, closing this as it turned out as issue in test automation. Will open a new bugzilla for the issue with double clicking the first tab spawning multiple requests to the backend.

Note You need to log in before you can comment on or make changes to this bug.