This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267881 - RFE: Don't chop off text in the middle of words when moving to new line in text mode
RFE: Don't chop off text in the middle of words when moving to new line in te...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 05:44 EDT by Alexander Todorov
Modified: 2017-01-11 09:55 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.77-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:14:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots of rescue and text mode (44.61 KB, image/png)
2016-06-10 02:52 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Alexander Todorov 2015-10-01 05:44:39 EDT
Description of problem:


Below is verbatim copy of the serial console. Notice how when we reach the 80 characters limit the text is chopped off. Please don't do this in the middle of words as they're harder to read. This probably needs to go upstream first.


Starting installer, one moment...
anaconda 21.48.22.53-1 for RHEL Atomic Host 7 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separate text/plain attachments
================================================================================
================================================================================
Rescue

The rescue environment will now attempt to find your Linux installation and moun
t it under the directory : /mnt/sysimage.  You can then make any changes require
d to your system.  Choose '1' to proceed with this step.
You can choose to mount your file systems read-only instead of read-write by cho
osing '2'.
If for some reason this process does not work choose '3' to skip directly to a s
hell.

 1) Continue

 2) Read-only mount

 3) Skip to shell

 4) Quit (Reboot)

Please make a selection from the above:  1
================================================================================
================================================================================
Rescue Mount

You don't have any Linux partitions. The system will reboot automatically when y
ou exit from the shell.
Please press <return> to get a shell. 
When finished, please exit from the shell and your system will reboot.
Comment 2 Radek Vykydal 2016-06-10 02:52 EDT
Created attachment 1166510 [details]
screenshots of rescue and text mode

All TextWidgets should be word wrapped by default now.
Comment 4 Michal Kovarik 2016-07-26 09:19:54 EDT
Verified on RHEL-7.3-20160719.1 with anaconda-21.48.22.80-1.el7.
Comment 6 errata-xmlrpc 2016-11-03 19:14:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.