Bug 1267892 - I'm unable to git push from Cloud9 [NEEDINFO]
I'm unable to git push from Cloud9
Status: CLOSED INSUFFICIENT_DATA
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miciah Dashiel Butler Masters
chaoyang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 06:32 EDT by arakkun
Modified: 2015-12-18 15:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 15:01:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mmasters: needinfo? (arakkun)


Attachments (Terms of Use)

  None (edit)
Description arakkun 2015-10-01 06:32:07 EDT
Description of problem:
I'm unable to use git push and as so, continue the project for a subject for the exams at the university, using a WEB IDE(Cloud9) (My laptop isn't working, so I'm preparing the project via Desktop and Cloud).

How reproducible:
Making some changes and pushing those changes.
In the past it somewhat actually worked... just for the first few times, after that it started doing the same error over and over.

Steps to Reproduce:
Pre-Step: download the rhc gem and all that is needed to use it and rhc setup plus git-clone the folder.
1.Make some changes to the folder
2.Use "git commit ..." to commit the changes
3.Use "git push"

Actual results:

Counting objects: 13, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (8/8), done.
Writing objects: 100% (8/8), 825 bytes | 0 bytes/s, done.
Total 8 (delta 6), reused 0 (delta 0)
remote: : command not found
remote: An error occurred executing 'gear prereceive' (exit code: 127)
remote: Error message: CLIENT_ERROR: Failed to execute: 'control stop' for /var/lib/openshift/***/ruby
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://***@treasurehunt-arakkun.rhcloud.com/~/git/treasurehunt.git/
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'ssh://***@treasurehunt-arakkun.rhcloud.com/~/git/treasurehunt.git/'

Even if it said the 'control stop' had some problem, in the page of the app within openshift it actually says it's "Stopped"

Expected results:
A successful push

Additional info:
I arleady tried rhc stop, force-stop, start and restart.
The result of those operations are:

Failed to execute: 'control stop' for /var/lib/openshift/***/ruby< though the app actually Stopped

RESULT:
treasurehunt force stopped

Failed to execute: 'control start' for /var/lib/openshift/***/ruby < though the app actually Started

RESULT:
treasurehunt restarted

(***) I saw another bug report hiding the alphanumeric code of the app
Comment 1 arakkun 2015-10-02 07:24:37 EDT
So:
-the bug is also present when I try to push from my computer and others WEB IDE
-the upload part of the git push work perfectly, as I git-cloned from other IDEs and the files where as I updated them on the IDEs I used before
-the version control part of the push doesn't. As the response of my pc to the "git pull" is that there were no updates on the code, so it doesn't download anything.
Comment 2 arakkun 2015-10-02 13:22:15 EDT
Jenkins Report of the build

Started by user Jenkins Admin
Building remotely on treasurehuntbldr (treasurehunt-build) in workspace /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo
Checkout:repo / /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo - hudson.remoting.Channel@1f2da77:treasurehuntbldr
Using strategy: Default
Checkout:repo / /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo - hudson.remoting.LocalChannel@1a0ce5
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository origin
Fetching upstream changes from ssh://55f02e560c1e66355f000028@treasurehunt-arakkun.rhcloud.com/~/git/treasurehunt.git
Seen branch in repository origin/HEAD
Seen branch in repository origin/master
Commencing build of Revision 74020183e09f2faaf1ca765d2afee3f7f172554d (origin/HEAD, origin/master)
Checking out Revision 74020183e09f2faaf1ca765d2afee3f7f172554d (origin/HEAD, origin/master)
No change to record in branch origin/HEAD
No change to record in branch origin/master
[repo] $ /bin/sh -xe /tmp/hudson5609790075915239859.sh
+ source /usr/lib/openshift/cartridge_sdk/bash/sdk
++ '[' false == true ']'
++ OO_BASH_SDK=true
+ alias 'rsync=rsync --delete-after -azS -e '\''/usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh'\'''
+ upstream_ssh=55f02e560c1e66355f000028@treasurehunt-arakkun.rhcloud.com
+ rm -f /var/lib/openshift/560eb9732d5271718600006f//app-deployments/current/metadata.json
+ marker_present force_clean_build
+ '[' -f /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo//.openshift/markers/force_clean_build ']'
+ set +e
+ rsync --delete-after -azS -e /usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh '55f02e560c1e66355f000028@treasurehunt-arakkun.rhcloud.com:$OPENSHIFT_BUILD_DEPENDENCIES_DIR' /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/build-dependencies/
Warning: Permanently added 'treasurehunt-arakkun.rhcloud.com,172.16.4.63' (RSA) to the list of known hosts.
+ rsync --delete-after -azS -e /usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh '55f02e560c1e66355f000028@treasurehunt-arakkun.rhcloud.com:$OPENSHIFT_DEPENDENCIES_DIR' /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/dependencies/
Warning: Permanently added 'treasurehunt-arakkun.rhcloud.com,172.16.4.63' (RSA) to the list of known hosts.
+ set -e
+ gear build
Building git ref 'origin/HEAD', commit 7402018
No such file or directory - /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo/.openshift/action_hooks/pre_build
Build step 'Execute shell' marked build as failure
Archiving artifacts
Finished: FAILURE


With Jenkins the push seems succesfull partially, but it still says


remote: **BUILD FAILED/CANCELLED**
remote: Please see the Jenkins log for more details via 'rhc tail'
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: CLIENT_ERROR: Failed to execute: 'control post-receive' for /var/lib/openshift/55f02e560c1e66355f000028/jenkins-client
remote:
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://55f02e560c1e66355f000028@treasurehunt-arakkun.rhcloud.com/~/git/treasurehunt.git/
   cd9715d..7402018  master -> master
Comment 3 Miciah Dashiel Butler Masters 2015-10-25 00:29:24 EDT
I have not been able to reproduce the problem.  Would you be able to provide the contents of your .openshift/ directory, or ideally a snapshot of your application so I can try to reproduce the problem? Are you able to reproduce the problem using only rhc and git commands, or do you see the problem only if you edit the project using Cloud9?
Comment 4 arakkun 2015-10-26 18:02:14 EDT
The problem was present with all ways I could find ( Codeaywhere, My PC, etc. )
It was because I had inserted a couple of things in the root of the folder, and the builder only had a limited number of files in the folder it built. ( I checked the folder with the ssh)
As so, I restarted the project and I didn't insert those things (a template) in the folder, and started to build all step by step.
Comment 5 Miciah Dashiel Butler Masters 2015-10-26 18:45:53 EDT
Thanks for the response! Do you mean that the builder hit its quota, or did the added files somehow cause problems in some other way? Can you provide more details such as the number of files, file sizes, and file names if relevant?
Comment 6 arakkun 2015-10-26 19:40:42 EDT
I don't think the file sizes, either the names do change something and I don't remember ( I didn't save a log of the experiment I ssh'd into ) the precise files that where there.
The oly thing I remember, is that the folder on my pc had n+x files, while the folder jenkins should have used ( so " /var/lib/openshift/560eb9732d5271718600006f/app-root/runtime/repo/" ) to build did have some file, but those file where the first n files you would find by sorting the files ad folder alphabetically, moving all the ".something" files to the last.
So the folder of the builder didn't really have any file or directory ".openshift/action_hooks/pre_build".
Comment 7 Miciah Dashiel Butler Masters 2015-11-30 15:09:28 EST
If you are able to reproduce the problem, can you provide output from the following commands?

quota

du -hs ~

ls -lR ~/app-root/repo/.openshift/action_hooks

If possible, it would also help if you could provide a snapshot (from `rhc snapshot save`) or Git repository for an application with which the problem could be reproduced.

Unless you or somebody else can provide a way to reproduce the problem, I'm afraid we don't have much to go on to fix it.
Comment 8 Miciah Dashiel Butler Masters 2015-12-11 14:58:59 EST
I have not been able to reproduce the errors, and we cannot resolve it unless we have more details or steps to reproduce the problem.  If you can reproduce the problem, please provide the following information.

First, SSH into your gear and check your quota, disk usage, and application hooks:

$ rhc ssh treasurehunt
> quota
> du -hs ~
> ls -lR ~/app-root/repo/.openshift/action_hooks

Please let me know the output of these commands.

If you are willing to share your application, please take a snapshot:

$ rhc app snapshot treasurehunt

Find and attach treasurehunt.tar.gz to this Bugzilla report.

Thanks!
Comment 9 Miciah Dashiel Butler Masters 2015-12-18 15:01:01 EST
I'm closing this Bugzilla report because we haven't been able to reproduce it or gather more details on the problem.

If you see the problem again, please re-open this Bugzilla report and provide details and steps to reproduce the problem.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.