This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267895 - glob pattern in <spec> definition does not work in queries
glob pattern in <spec> definition does not work in queries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 06:37 EDT by Vít Ondruch
Modified: 2017-02-08 09:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-08 09:51:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2015-10-01 06:37:52 EDT
Description of problem:
I want to remove all kerne packages of specific version, but it does not work:


$ rpm -q kernel-modules
kernel-modules-4.3.0-0.rc2.git1.1.fc24.x86_64
kernel-modules-4.2.1-300.fc23.x86_64
kernel-modules-4.3.0-0.rc3.git1.1.fc24.x86_64


# dnf remove 'kernel*4.3.0-0.rc3*' 
No match for argument: kernel*4.3.0-0.rc3*
Error: No packages marked for removal.



Version-Release number of selected component (if applicable):


How reproducible:
$ rpm -q dnf
dnf-1.1.2-3.fc24.noarch


Steps to Reproduce:
1. dnf remove 'kernel*4.3.0-0.rc3*'
2.
3.

Actual results:
# dnf remove 'kernel*4.3.0-0.rc3*' 
No match for argument: kernel*4.3.0-0.rc3*
Error: No packages marked for removal.

Expected results:
All kernel* packages of specified version are removed.


Additional info:
Comment 1 Honza Silhan 2015-10-13 09:35:48 EDT
Use separators, please. http://dnf.readthedocs.org/en/latest/command_ref.html#specifying-packages
Comment 2 Vít Ondruch 2015-10-13 10:13:04 EDT
Could you please give me an example? I definitely saw this page before, but still fail to find the right combination.
Comment 3 Vít Ondruch 2015-10-13 10:24:48 EDT
Actually this seems to work:

$ LANG=en_US sudo dnf remove 'kernel*-4.3.0-0.rc2.git1.1.fc24'
Dependencies resolved.
================================================================================
 Package               Arch    Version                     Repository      Size
================================================================================
Removing:
 kernel                x86_64  4.3.0-0.rc2.git1.1.fc24     @@commandline    0  
 kernel-core           x86_64  4.3.0-0.rc2.git1.1.fc24     @@commandline   53 M
 kernel-modules        x86_64  4.3.0-0.rc2.git1.1.fc24     @@commandline   18 M
 kernel-modules-extra  x86_64  4.3.0-0.rc2.git1.1.fc24     @@commandline  2.2 M

Transaction Summary
================================================================================
Remove  4 Packages

Installed size: 74 M
Is this ok [y/N]: n



But not with any wildcard in release:



$ sudo dnf remove 'kernel*-4.3.0-0.rc2*'
No match for argument: kernel*-4.3.0-0.rc2*
Error: No packages marked for removal.
Comment 4 Jan Kurik 2016-02-24 08:48:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Fedora Admin XMLRPC Client 2016-07-08 05:31:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Jaroslav Mracek 2016-12-16 10:51:28 EST
The problem with glob in release will be fixed in pull-request: https://github.com/rpm-software-management/libhif/pull/229
Comment 7 Jaroslav Mracek 2016-12-16 10:56:15 EST
*** Bug 1381506 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Mracek 2017-02-08 09:51:36 EST
Patch released in rawhide libdnf-0.7.2-1.fc26

Note You need to log in before you can comment on or make changes to this bug.