Bug 1267910 - PSQLException when insert value to audit log if input string is too long
PSQLException when insert value to audit log if input string is too long
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: AAA (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Ravi Nori
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 07:29 EDT by Ondra Machacek
Modified: 2016-07-27 08:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 08:54:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
masayag: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
engine.log (19.19 KB, text/plain)
2015-10-01 07:29 EDT, Ondra Machacek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47672 master MERGED engine : PSQLException when insert value to audit log if input string is too long Never
oVirt gerrit 47805 ovirt-engine-3.6 ABANDONED engine : PSQLException when insert value to audit log if input string is too long Never

  None (edit)
Description Ondra Machacek 2015-10-01 07:29:02 EDT
Created attachment 1079052 [details]
engine.log

Description of problem:


Version-Release number of selected component (if applicable):
3.6.0-15

How reproducible:
always

Steps to Reproduce:
1. Generate 247 chars long string (python -c 'print "A"*247')
2. into username field of webadmin login page insert this string a login

Actual results:
Action failed due to database connection failure. Please check connectivity to your Database server.

Expected results:
Login failed. Please verify your login information or contact the system administrator.

Additional info:
Comment 1 Alon Bar-Lev 2015-10-01 10:56:24 EDT
not sure this should not be generic error, just like any other internal command error.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:53:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Gil Klein 2016-07-27 08:54:26 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.