Bug 1267984 - ::ceilometer::config class missing in overcloud_controller*.pp and overcloud_compute.pp manifests [NEEDINFO]
Summary: ::ceilometer::config class missing in overcloud_controller*.pp and overcloud_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Jay Dobies
QA Contact: Giulio Fidente
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-01 14:08 UTC by Gaëtan Trellu
Modified: 2016-04-07 21:41 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.7-5.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-07 21:41:07 UTC
Target Upstream Version:
yprokule: needinfo? (jason.dobies)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 230531 0 None None None Never
Red Hat Product Errata RHEA-2016:0604 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 director Enhancement Advisory 2016-04-08 01:03:56 UTC

Description Gaëtan Trellu 2015-10-01 14:08:53 UTC
Description of problem:

We want to setup Ceilometer by changing some value via Hiera. The problem is these changes are not applied.

Version-Release number of selected component (if applicable):
rhos-release-0.72-1.noarch
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch
puddle images 2015-08-07.1

How reproducible:

Add theses options to controller.yaml:
# ceilometer
ceilometer::rpc_backend: 'rabbit'
ceilometer::config::ceilometer_config:
  DEFAULT/notification_driver:
    value: 'messaging'
  notification/ack_on_event_error:
    value: 'true'
  notification/store_events:
    value: 'true'

Run the deployment.

Actual results:

Nothing changed in the /etc/ceilometer/ceilometer.conf

Expected results:

Changes applied in the /etc/ceilometer/ceilometer.conf

Additional info:

To solve the issue, we have to include the ::ceilometer::config class in the overcloud_controller.pp, overcloud_controller_pacemaker.pp and overcloud_compute.pp files.

puppet/manifests/overcloud_compute.pp
puppet/manifests/overcloud_controller.pp
puppet/manifests/overcloud_controller_pacemaker.pp

Comment 3 Emilien Macchi 2015-10-02 16:20:13 UTC
https://review.openstack.org/230531

Comment 7 Giulio Fidente 2016-03-29 13:37:49 UTC
It's possible to specify arbitrary config settings for Ceilometer via ::ceilometer::config using openstack-tripleo-heat-templates-0.8.12-2.el7ost.noarch.rpm

Comment 9 errata-xmlrpc 2016-04-07 21:41:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html


Note You need to log in before you can comment on or make changes to this bug.