Bug 126799 - Header file dbus-arch-deps.h is installed in weird location
Summary: Header file dbus-arch-deps.h is installed in weird location
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-27 05:27 UTC by Daryll
Modified: 2016-10-24 13:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 21:22:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daryll 2004-06-27 05:27:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8 StumbleUpon/1.906

Description of problem:

The dbus.h file includes all the other dbus header files including one
called dbus-arch-deps.h. That file is installed in
/usr/lib/dbus-1.0/include/dbus instead of /usr/include/dbus-1.0/dbus.
That seems to be a mistake.



Version-Release number of selected component (if applicable):
0.20-4.1

How reproducible:
Always

Steps to Reproduce:

Try to #include <dbus.h> with only -I/usr/include/dbus-1.0 on your
command line

Actual Results:  header fiel dbus-arch-deps.h isn't found

Expected Results:  It should compile.

Additional info:


Adding -I/usr/lib/dbus-1.0/include will work around the problem.

Comment 1 John (J5) Palmieri 2004-09-09 21:22:27 UTC
You should be using pkg-config to get include paths.  For example:

pkg-config --libs --cflags dbus-1

This correctly puts both -I/usr/include/dbus-1.0 and
-I/usr/lib/dbus-1.0/include in your argument list.

As for the location of header files I suggest filing a bug upstream or
asking why about this on the dbus mailing list.




Note You need to log in before you can comment on or make changes to this bug.