Bug 1267990 - Connection Errors in log during katello-service restart
Connection Errors in log during katello-service restart
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 10:16 EDT by Dennis Kliban
Modified: 2017-01-12 10:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 10:10:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Kliban 2015-10-01 10:16:13 EDT
Description of problem:

Pulp workers throw connection exceptions during a restart of katello services. This is due to the message broker being restarted before the workers are shut down. 

The services work properly afterwards, however, this looks bad to the user.



Steps to Reproduce:
  1. katello-service restart
  2. Look in logs
  3. See connection errors in log

Actual results:

  Errors in log

Expected results:

  No errors in log.
Comment 1 Brad Buckingham 2015-10-14 11:28:32 EDT
Hi Dennis,  can you attach a foreman-debug or other text that shows examples of the errors?
Comment 2 Dennis Kliban 2015-10-26 09:21:40 EDT
I don't have a sample of log output. Someone in #satellite6 mentioned seeing these errors in their logs. I looked at the order in which services are shut down and it made sense to me that it would possible for pulp workers to spew connection errors when the broker is shut down before the workers are turned off.
Comment 3 Bryan Kearney 2016-07-26 15:11:06 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Bryan Kearney 2017-01-12 10:10:46 EST
This is an older bug which I do not envision being fixed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.