Bug 1268002 - pydoc issue
pydoc issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-access-insights (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: jcrafts
Martin Kyral
: Rebase
Depends On:
Blocks: 1298112
  Show dependency treegraph
 
Reported: 2015-10-01 10:35 EDT by Branislav Náter
Modified: 2016-11-04 04:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, one required root access to access Red Hat Insights pydoc documentation. Special privileges are no longer needed.
Story Points: ---
Clone Of:
: 1295935 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Náter 2015-10-01 10:35:56 EDT
Description of problem:
I've hit this issue when running upstream python tests and have redhat-access-insights installed. test_pydoc.py failed:

======================================================================
FAIL: test_apropos_with_bad_package (test.test_pydoc.PydocImportTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python2.7/test/test_pydoc.py", line 341, in test_apropos_with_bad_package
    result = run_pydoc('zqwykjv', '-k', PYTHONPATH=TESTFN)
  File "/usr/lib64/python2.7/test/test_pydoc.py", line 196, in run_pydoc
    rc, out, err = assert_python_ok('-B', pydoc.__file__, *args, **env)
  File "/usr/lib64/python2.7/test/script_helper.py", line 55, in assert_python_ok
    return _assert_python(True, *args, **env_vars)
  File "/usr/lib64/python2.7/test/script_helper.py", line 47, in _assert_python
    "stderr follows:\n%s" % (rc, err.decode('ascii', 'ignore')))
AssertionError: Process return code is 1, stderr follows:
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Red Hat Access Insights must be run as root

Version-Release number of selected component (if applicable):
redhat-access-insights-1.0.6-0.el7

How reproducible:
1. create user "test"
# useradd test

2. login as user test
# su - test

3. run pydoc -k
$ pydoc -k something
Red Hat Access Insights must be run as root

So basically just searching documentation as non-root user produce "Red Hat Access Insights must be run as root" error message.
On the other side, redhat-access-insights have to be run under root user so I'm not sure if this is fixable.
Comment 2 Dan Varga 2015-10-01 12:11:10 EDT
So I believe that this "Must be run as root" check can be moved and hopefully we can avoid this.
Comment 3 jcrafts 2015-12-11 15:38:34 EST
This has been fixed by the following commit:
https://github.com/redhataccess/insights-client/commit/e2281feef75338c6f7c95fa9e2cecb7584374951
Comment 5 Mike McCune 2016-03-28 18:44:25 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 errata-xmlrpc 2016-11-04 04:23:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2542.html

Note You need to log in before you can comment on or make changes to this bug.