Bug 1268027 - ipa-dnskeysync-replica crash with backtrace - LimitsExceeded: limits exceeded for this query
ipa-dnskeysync-replica crash with backtrace - LimitsExceeded: limits exceeded...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 11:31 EDT by Kaleem
Modified: 2016-11-04 01:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:47:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash detailed info (2.99 KB, text/plain)
2015-10-01 11:31 EDT, Kaleem
no flags Details

  None (edit)
Description Kaleem 2015-10-01 11:31:20 EDT
Created attachment 1079191 [details]
crash detailed info

Description of problem:
Observed this crash while executing B&R automated regression run.

Crash shows time that it occured at 08:45:45 AM but when i looked into the beaker logs, i found that at that time ipa installation was in progress. Point to note is that it was in second test case. In First test case, i did install/full backup/uninstall/install/full restore/uninstall. 

snip from crash:
================
time:           Thu 01 Oct 2015 08:54:45 AM EDT
cmdline:        /usr/bin/python2 /usr/libexec/ipa/ipa-dnskeysync-replica
uid:            993 (ods)
abrt_version:   2.1.11
dso_list:       ipa-python-4.2.0-12.el7.x86_64
event_log:      
executable:     /usr/libexec/ipa/ipa-dnskeysync-replica
hostname:       ibm-dx360m4-01.testrelm.test
kernel:         3.10.0-320.el7.x86_64
last_occurrence: 1443704085
pid:            16985
pkg_arch:       x86_64
pkg_epoch:      0
pkg_name:       ipa-server
pkg_release:    12.el7
pkg_version:    4.2.0
runlevel:       N 3
username:       ods

beaker log snip with timestamp:
===============================

:: [ 08:49:57 ] ::   ipa-server-4.2.0-12.el7.x86_64
:: [  BEGIN   ] :: Running ' /usr/sbin/ipa-server-install --setup-dns --forwarder=10.16.36.29 --hostname=ibm-dx360m4-01.testrelm.test -r TESTRELM.TEST -n testrelm.test -p xxxxxxxx -a xxxxxxxx --ip-address=10.16.67.102 -U'
....
Be sure to back up the CA certificates stored in /root/cacert.p12
These files are required to create replicas. The password for these
files is the Directory Manager password
:: [   PASS   ] :: Command ' /usr/sbin/ipa-server-install --setup-dns --forwarder=10.16.36.29 --hostname=ibm-dx360m4-01.testrelm.test -r TESTRELM.TEST -n testrelm.test -p xxxxxxxx -a xxxxxxxx --ip-address=10.16.67.102 -U' (Expected 0, got 0)
:: [ 08:56:29 ] :: Check ldap_sasl_authid is not added to sssd.conf
:: [ 08:56:30 ] :: Verifying BZ 878420

Version-Release number of selected component (if applicable):
  ipa-server.x86_64 0:4.2.0-12.el7 

How reproducible:


Steps to Reproduce:
1.See description section

Actual results:
Crash seen

Expected results:
No crash

Additional info:
Please find the attached crash detailed info
Comment 2 Petr Vobornik 2015-10-05 06:38:12 EDT
Kaleem, could you attach a DS error and access log from the time of the crash?
Comment 3 Petr Spacek 2015-10-06 03:47:09 EDT
This is most likely caused by weirness in IPA ldap2 class - DS did not respond in 2 second limit for configuration refresh and that caused this error.

This issue will manifest itself randomly. To workaround that we can easily change DNSSEC daemons to use different code from IPA framework to avoid the problematic query from withing ldap2 class.

Patch was sent to the ipa-devel list.
Comment 4 Martin Bašti 2015-10-06 03:50:14 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5342
Comment 8 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 Abhijeet Kasurde 2016-09-23 05:30:03 EDT
Verified using IPA version::
ipa-server-4.4.0-11.el7.x86_64

Done SanityOnly using automation.
Comment 11 Kaleem 2016-09-23 06:32:04 EDT
Crash no more seen with automated test suite.
Comment 13 errata-xmlrpc 2016-11-04 01:47:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.