Bug 1268028 - checking "Manually attach subscriptions after registration" does not work in initial-setup
checking "Manually attach subscriptions after registration" does not work in ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 11:31 EDT by John Sefler
Modified: 2015-11-19 06:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
auto-attach (122.96 KB, image/png)
2015-10-01 13:16 EDT, Rehana
no flags Details
Register with auto-attach (98.00 KB, image/png)
2015-10-12 04:26 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description John Sefler 2015-10-01 11:31:45 EDT
Description of problem:
If I check the "Manually attach subscriptions after registration" box during the registration process within initial-setup, the workflow behaves as though I did not check it.  Auto-binding appears to proceed and can lead me to a Select Service Level panel that has no navigation buttons displayed and I get stuck. 

Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager-initial-setup-addon
subscription-manager-initial-setup-addon-1.15.9-13.el7.x86_64


How reproducible:


Steps to Reproduce:
1. With two product certs installed that are not covered by a subscription with the same service level, start initial-setup and proceed to register to a valid account and choose "Manually attach subscriptions after registration" checkbox.


Actual results:


Expected results:
registration should complete without attempting to attach any subscriptions.

Additional info:
Comment 2 Adrian Likins 2015-10-01 12:02:31 EDT
upstream pr at https://github.com/candlepin/subscription-manager/pull/1313
Comment 3 Adrian Likins 2015-10-01 12:09:06 EDT
Notes on the wacky behavior:

After register, we were async starting 'finished' _and_ moving to the select sla screen (and it's long pre/startup). So gui would momentarily show the done screen, pause the progress bars, (and for initial-setup, hide the nav buttons) while the select sla screen was also showing a now paused progress bar and eventually whatever the results of select slas pre() was (potentially including error info). Basically, it finished, and then started select sla anyway.
Comment 4 Rehana 2015-10-01 13:15:25 EDT
Scenario 2 :

RHSM registration from initial-setup with "auto-attach" ( without checking "Manually attach subscriptions after registration ) is taking to "Confirm Subscriptions" page again and again

steps:

1.Launch initial setup
2.Register client to stage environment with OUT checking the option "Manually attach subscriptions after registration"
3.Message " Error subscribing unit" is displayed (PFA) 

Expected result:

system should get successfully registered and subscribed to the available matching subscription.
Comment 5 Rehana 2015-10-01 13:16 EDT
Created attachment 1079211 [details]
auto-attach
Comment 6 Chris Snyder 2015-10-01 13:47:14 EDT
commit 576c025b34c9d80b14031c2fb40719998eec541a
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Oct 1 11:55:05 2015 -0400

    1268028: Fix skipped auto attach in registergui
    
    When using initial-setup to register a system, if the
    'Manually attach subscriptions after registration' option
    was selected in the credentials page, the gui would
    start the select sla screen before starting the 'done'
    process. So the done screen could be shown, then a
    now paused progress bar, then eventually the results of
    the select sla screens startup.
    
    Fix is just to either finish, or start select sla, not
    both.
Comment 11 Shwetha Kallesh 2015-10-12 04:26 EDT
Created attachment 1081906 [details]
Register with auto-attach

Marking verified as register with and without auto-attach on a system with installed products that are not covered by same service-level thro initial-setup is working fine.


[root@dhcp35-36 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.17
subscription-manager: 1.15.9-14.el7
python-rhsm: 1.15.4-5.el7
Comment 12 errata-xmlrpc 2015-11-19 06:51:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.