Bug 126803 - kernel panic during boot with SMP 2.6.6.-1.435 kernel
kernel panic during boot with SMP 2.6.6.-1.435 kernel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 09:00 EDT by Steve Underwood
Modified: 2015-01-04 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Underwood 2004-06-27 09:00:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I upgraded a year old, known reliable, dual Xeon machine from RH9 to
FC2, and immediately updated all its RPMs to the latest. I can boot OK
with the single CPU kernel. When I boot with the SMP kernel I get a
panic during startup. The trackback starts in the PS/2 mouse
interrupt, and works up through the i8042 code. I have found several
people complaining about this in mailing lists, but I can't find it in
the bug database where it belongs. :-)

Occassionally, the machine will boot. If it gets past the troublesome
point it seems to work OK from then on. It only succeeded a couple of
times out of more than 10.

Machine:

Tyan 2665 M/B, 2 x 2.4GHz HT Xeons, 1G RAM, BIOS 1.13, HT enabled
IDE disks
PS/2 keyboard and mouse
No SCSI devices attached to the SCSI controllers.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.6-1.435

How reproducible:
Sometimes

Steps to Reproduce:
1. Upgrade to FC2 with the 2.6.6-1.435 kernel
2. Boot the SMP version of the kernel
3. Get annoyed :-)
    

Additional info:
Comment 1 Richard Lee 2004-07-16 18:26:15 EDT
I have seen this problem as well.  When I try to boot with the 435 or
435.2.3 smp kernel, i get a null pointer crash in the kernel
immediately on bootup.  it doesn't get as far as the ps/2 code.
Comment 2 Ian Collier 2004-08-17 10:12:37 EDT
I have seen this too, so here's some more information.
The system is a dual Intel(R) Xeon(TM) CPU 3.20GHz with
hyperthreading.

Under the original 2.6.5-1.358 SMP kernel the machine booted
but the keyboard and mouse were somewhat mixed up (in text mode
the keyboard worked if plugged into the mouse port, but under X11
both the PS/2 ports behaved as mouse ports and a USB keyboard had
to be used - luckily this machine is a server, so doesn't usually
need a keyboard attached).

2.6.6-1.435smp and (just recently) 2.6.7-1.494.2.2smp both fail to
boot, although the single-processor versions do work.  The crash
dumps differ (sometimes mentioning badness in do_unblank_screen at
drivers/char/vt.c:2860), but here's a typical one (via scribbling
on a piece of paper, so I haven't copied down all the symbolic
locations or the whole stack dump).

mice: PS/2 mouse device common for all mice
Failed to disable AUX port, but continuing anyway... is this a SiS?
If AUX port is really absent please use the 'i8042.noaux' option.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Unable to handle kernel NULL pointer dereference at virtual address
00000000
 printing eip:
00000000
*pde=00003001
Oops: 0000[#1]
SMP
Modules linked in:
CPU: 0
EIP: 0060:[<00000000>] Not tainted
EFLAGS: 00010217 (2.6.7-1.494.2.2smp)
EIP is at 0x0
 eax: 39e74000  ebx: 39e74000  ecx: 00000000  edx: 00000000
 esi: 00000000  edi: 0234b6a0  ebp: 0234b6a0  esp: 81f30f04
 ds: 007b  es: 007b  ss: 0068
process swapper (pid: 1, threadinfo=81f30000 task=39ff16f0)
Stack: 0226adb3 00000000 00000000 0234b440 00000000 39e746f0 0226ce48
00000000

Call Trace:
 [<0226adb3>] psmouse_interrupt + 0x1c1/0x272
 [<0226ce48>] serio_interrupt + 0x21/0x53
 [<0226d6a2>] i8042_interrupt + 0x158/0x16b
 [<0226d4b8>] i8042_open + 0xf/0x23
 [<0226d0b5>]
 [<0226b5f3>]
 [<0226cb07>]
 [<0226ceaf>]
 [<023aaa21>]
 [<023aabb7>]
 [<023917ec>] do_initcalls + 0x49/0x97
 [<021004f1>] init + 0xc2/0x1b8
 [<0210042f>] init + 0x0/0x1b8
 [<021041f1>] kernel_thread_helper + 0x5/0x6
Code: bad EIP value
<0> kernel panic: Attempted to kill init!

Anyway, Bug 124138 mentions going into the BIOS and turning off
"legacy USB support".  Now I've done that the machine boots 
successfully and also correctly recognises the keyboard and mouse.

Before I did that, I also tried booting with a bunch of i8042.*
kernel parameters (namely: direct, noaux, nomux and reset all at
once).  The result of that was the message:

kernel: i8042.c: i8042 controller selftest failed. (0x0 != 0x55)

and no keyboard or mouse support at all, but at least it did boot.
Comment 3 Dave Jones 2004-11-27 15:21:56 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 4 Dave Jones 2005-04-16 00:17:45 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.