Bug 1268054 - texlive.macros borked
texlive.macros borked
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 13:05 EDT by Rex Dieter
Modified: 2015-10-13 13:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: texlive-2014-14.20140525_r34255.fc23 texlive-2014-11.20140525_r34255.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 15:14:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2015-10-01 13:05:16 EDT
$ rpm -q -f /usr/lib/rpm/macros.d/macros.texlive 
texlive-base-2014-13.20140525_r34255.fc23.noarch

$ cat /usr/lib/rpm/macros.d/macros.texlive | head
#!/bin/sh
#
# This script creates texlive.spec from generated specs by tl2rpm
# and generates local testing repository from built packages.
# Written by Jindrich Novy (novyjindrich@gmail.com).
#
gcc tl2rpm.c -o tl2rpm -O2 -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=native -march=native
[ "$?" != "0" ] && exit 1
rm -f _mkdirs.spec _unpack.spec _sources.spec _remove.spec _packages.spec _font.spec _files.spec _dirs.spec
touch _mkdirs.spec


Looks like this is to blame, texlive.spec snippet:
...
Source9: b_one_srpm
Source10: macros.texlive
...
# create macro file for building texlive
mkdir -p %{buildroot}%{macrosdir}
cp -a %{SOURCE9} %{buildroot}%{macrosdir}/macros.texlive


Looks like the wrong source file is getting installed as macros.texlive
Comment 1 Fedora Update System 2015-10-01 22:53:53 EDT
texlive-2014-11.20140525_r34255.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3
Comment 2 Fedora Update System 2015-10-01 22:53:53 EDT
texlive-2014-14.20140525_r34255.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4
Comment 3 Fedora Update System 2015-10-03 21:36:34 EDT
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3
Comment 4 Fedora Update System 2015-10-03 21:52:39 EDT
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4
Comment 5 Fedora Update System 2015-10-04 15:14:12 EDT
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-10-13 13:02:28 EDT
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.