Bug 1268060 - s-m-gui register dialog should have a Close button. Again. Really.
s-m-gui register dialog should have a Close button. Again. Really.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: candlepin-bugs
Sean Toner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 13:26 EDT by Adrian Likins
Modified: 2015-11-19 06:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
register dialogs with a close button (87.07 KB, application/x-gzip)
2015-10-12 08:28 EDT, Sean Toner
no flags Details

  None (edit)
Description Adrian Likins 2015-10-01 13:26:11 EDT
Description of problem:
There is no on screen way to close the registergui dialog in subscription-manager-gui now since 'back' replaced 'cancel' and the dialog type means no wm 'x' close button.

Version-Release number of selected component (if applicable):
subscription-manager-1.15.9-13

How reproducible:


Steps to Reproduce:
Open 'Register' or 'Auto Attach' dialog.
Try to close it.

Actual results:
No obvious way (esc/alt-f4/wm right click->close still work)

Expected results:
A cancel button. We all love cancel buttons.
We should add 5 or 6 of them.

Don't do that. Just one please.
Comment 1 Adrian Likins 2015-10-01 13:28:31 EDT
upstream pr at https://github.com/candlepin/subscription-manager/pull/1314
Comment 3 Barnaby Court 2015-10-02 11:18:20 EDT
Use a Close button instead of Cancel as we are closing the window and not reversing changes.
Comment 4 John Sefler 2015-10-06 11:20:23 EDT
Proposing as a blocker for rhel-7.2.0 to reinstate the Cancel/Close button that is already familiar to users of subscription-manager-gui from the prior rhel-7.1.0 release.
Comment 9 Sean Toner 2015-10-12 08:26:04 EDT
All the subdialogs of the registration process now have a Close button on the far left.  I tried registering a system and at each point clicked the Close button (even if there was a progress slider).  At each point the Close button would close out of the Register dialog.

The actual registration was not prevented from occurring however.  For example, after entering the username and password and clicking next, even though there is a progress slider while the system tries to register, if the user clicks Close at this point all it does is close the dialog.  The user will see that the system actually does register (though it will not auto-attach).

However, this more closely reflects the definition of close.  It does not cancel the registration process, nor does it bring the user back to a previous stage of the Registration process.

Attached are the various steps during registration where the Close button is visible.  The register-with-close-after-user-pw.png shows what the user will see if at some point after entering the username and password and hitting next, on the following dialog the Close button is clicked.  It shows that the system is actually registered.
Comment 10 Sean Toner 2015-10-12 08:28 EDT
Created attachment 1081991 [details]
register dialogs with a close button

Tested on 

[root@dhcp129-49 ~]# rpm -qa | grep subscription
subscription-manager-1.15.9-14.el7.x86_64
subscription-manager-gui-1.15.9-14.el7.x86_64
subscription-manager-initial-setup-addon-1.15.9-14.el7.x86_64
Comment 11 errata-xmlrpc 2015-11-19 06:51:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.