Bug 1268072 - Setting When to Provision to Schedule fails to load schedule fields and returns to Immediately on Approval
Setting When to Provision to Schedule fails to load schedule fields and retur...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity unspecified
: GA
: 5.5.0
Assigned To: Aparna Karve
Jeff Teehan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 14:36 EDT by Jeff Teehan
Modified: 2015-12-08 08:34 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 08:34:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hour and minutes popups have zero formatting. (19.95 KB, image/png)
2015-11-02 14:43 EST, Jeff Teehan
no flags Details

  None (edit)
Description Jeff Teehan 2015-10-01 14:36:09 EDT
Description of problem:

I was attempting to schedule the provisioning of a VM to verify another bug.  After filling in all the other sections, I clicked the Schedule Tab.  At Schedule Info - When to Provision I clicked the Schedule radio button.

The spinner spins for less then 5 seconds and the Immediately on Approval is reselected.

I attempted the exact VM provision request using 5.4.2 (https://10.8.59.82/vm_infra/explorer) and it worked just fine.

Version-Release number of selected component (if applicable):

Using 5.5.0.3 (https://10.8.59.195/vm_infra/explorer)
Using 5.5.0.2 (https://10.8.59.190/vm_infra/explorer)

How reproducible:

I was able to reproduce this using Chrome and Firefox.  It always fails in this manner.

Steps to Reproduce:
1.  Setup appliance with a provider which has VM templates.  I used vsphere55
2.  Navigate to Infrastructure - Virtual Machines - Lifecycle - Provision VMs
3.  Complete all sections saving the Schedule tab for last.
4.  Attempt to select the Schedule radio button.

Actual results:

Reselects the Immediately radio button after a few seconds

Expected results:

Expected the Provision On and the Starting Time fields to be displayed.

Additional info:

Please feel free to contact me or use any of the appliances referenced above.
Comment 3 CFME Bot 2015-10-02 16:30:25 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/898ab4b505bd51007b8dbf00c757e0c402f7c65e

commit 898ab4b505bd51007b8dbf00c757e0c402f7c65e
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Fri Oct 2 12:09:48 2015 -0700
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Fri Oct 2 12:09:48 2015 -0700

    PF Tabs in the Prov. dialog should be referenced by their tab name
    
    Removed the trailing "_div" since the tab names do not have that
    anymore.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1268072

 app/views/miq_request/_prov_field.html.haml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 4 Jeff Teehan 2015-11-02 14:43 EST
Created attachment 1088710 [details]
Hour and minutes popups have zero formatting.
Comment 5 Jeff Teehan 2015-11-02 14:45:23 EST
The fields are now present but the formatting looks bad.  I tried on a bunch of browsers.

Let me know if this is a new bug.

https://10.16.5.117/vm_infra/explorer 5.5.0.8 While it exists
Comment 6 Aparna Karve 2015-11-02 15:07:56 EST
Yes, please open a new BZ for any formatting issues.

Thanks
Comment 7 Jeff Teehan 2015-11-02 15:17:12 EST
Moving this bug to verified and opening a new bug for the formatting issue.

The scheduling works correctly with the fix.
Comment 9 errata-xmlrpc 2015-12-08 08:34:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2015:2551

Note You need to log in before you can comment on or make changes to this bug.