Bug 1268087 - pasting of text with crazily long lines pushes vimx over the top (100% CPU for couple of minutes)
pasting of text with crazily long lines pushes vimx over the top (100% CPU fo...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vim (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Karsten Hopp
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 15:06 EDT by Matěj Cepl
Modified: 2016-01-21 07:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 07:45:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test file (8.84 KB, text/plain)
2015-10-01 15:06 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2015-10-01 15:06:11 EDT
Created attachment 1079242 [details]
test file

Description of problem:
When pasting a crazily output of some bug testing to vimx via clipboard, vimx got seriously upset.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.open the attached file in some editor (perhaps even just with Firefox)
2.select all text and copy it to clipboard
3.switch to open vimx in the console and "+p

Actual results:
vimx pastes just couple of lines and with that crazily long one turns CPU to 100% and cannot get over it (after five minutes waiting, I have killed it)

Expected results:
just paste the text as other editors (e.g., gedit) do! no CPU should get involved with the text of 9k.

Additional info:
Comment 1 Matěj Cepl 2015-10-01 15:07:18 EDT
Sorry, forgot to add that I use vim-X11-7.4.160-1.el7.x86_64
Comment 3 Matěj Cepl 2015-10-01 15:29:07 EDT
Hmm, that 100% was quite pesimist estimate. Cannot reproduce anymore. The whole text is not displayed, but no CPU is involved anymore. Sorry.
Comment 4 Karsten Hopp 2016-01-21 07:45:01 EST
closing per comment #3

Note You need to log in before you can comment on or make changes to this bug.