Bug 1268088 - Trim message under subscription-manage spoke Icon, when the system is registered
Trim message under subscription-manage spoke Icon, when the system is registered
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Chris Snyder
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 15:07 EDT by Rehana
Modified: 2015-11-19 06:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spoke_message (157.48 KB, image/png)
2015-10-01 15:08 EDT, Rehana
no flags Details
Suggestion 1 (47.88 KB, image/png)
2015-10-01 17:23 EDT, John Sefler
no flags Details
Suggestion 2 (132.62 KB, image/png)
2015-10-01 17:26 EDT, John Sefler
no flags Details
Suggestion 3 (130.02 KB, image/png)
2015-10-01 17:28 EDT, John Sefler
no flags Details
register_msg (41.84 KB, image/png)
2015-10-08 10:08 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2015-10-01 15:07:53 EDT
Description of problem:
Observed that when the system is registered to RHSM , and long message is displayed "the system has been registered with id : <> 

Version-Release number of selected component (if applicable):
subscription-manager: 1.15.9-13.el7
python-rhsm: 1.15.4-5.el7


How reproducible:
2/2

Steps to Reproduce:
1.REgister client to RHSM from initial -setup
2.click DOne once the registration process is completed
3.

Actual results:
 long message is displayed "the system has been registered with id : <>  (PFA)

Expected results:
A short message would fix the issue like "System is registered to RHSM"

Additional info:
Comment 1 Rehana 2015-10-01 15:08 EDT
Created attachment 1079244 [details]
spoke_message
Comment 2 John Sefler 2015-10-01 17:18:08 EDT
Here are my suggestions...

1. Move "The system has been registered with ID: %s " from beneath the spoke icon to the final panel of the subscription-manager-initial-setup-addon workflow where you are currently displaying "Registration with Red Hat Subscription Management is Done!"  I think this is more informative and avoids seeing the word "Done" on the final screen in two places.

2. Display a short message "This system is registered." beneath the spoke icon after registration is done.  (Note: this string does not exist among the translated 1.15.X strings)

3. Display a short message "This system is currently not registered." or "System is not registered." beneath the spoke icon before registration happens.  (Note: both of these two strings have already been translated.)  In version subscription-manager-initial-setup-addon-1.15.9-13.el7 the is no message being displayed and it looks a little finny when the other spokes are displaying a message.
Comment 3 John Sefler 2015-10-01 17:23 EDT
Created attachment 1079271 [details]
Suggestion 1
Comment 4 John Sefler 2015-10-01 17:26 EDT
Created attachment 1079274 [details]
Suggestion 2
Comment 5 John Sefler 2015-10-01 17:28 EDT
Created attachment 1079276 [details]
Suggestion 3
Comment 6 Barnaby Court 2015-10-02 10:37:12 EDT
Addendum for suggestion 2

I would suggest using the existing string "System '%s' successfully registered.\n" for the immediate release, this will at least ensure that 'registered' is the last word which will be displayed in the text block.
Comment 9 Chris Snyder 2015-10-06 13:55:43 EDT
commit a77b142e2e6635f4401719979942cf8b3e401aad
Author: Christopher Snyder <csnyder@redhat.com>
Date:   Fri Oct 2 12:17:32 2015 -0400

    1268088: Changes the rhsm spoke display message to end with "registered"
    
    Rhsm spoke status is set on initialization of the spoke
    
    Fixes initially displayed string to match the translated one
    
    Changes the status set when the system is already registered

John Sefler's suggestions 2 (with Barnaby Court's addendum) and 3 have been implemented and merged into upstream master to resolve this bug.

If an implementation of John Sefler's suggestion 1 is desired, please open a new bug to track it.
Comment 14 Rehana 2015-10-08 10:07:13 EDT
Retested on 

subscription-manager: 1.15.9-14.el7
python-rhsm: 1.15.4-5.el7

1.On a unregistered system , rhsm spoke on initial-setup is displayed as  "This system is currently not registered" 

2.After successful registration, msg "system <id> successfully registered" is displayed <pfa: register_msg.png)

3.On a already registered machine , msg :  "System Already Registered" is displayed.


based on above observations , marking this bug to verified.
Comment 15 Rehana 2015-10-08 10:08 EDT
Created attachment 1081016 [details]
register_msg
Comment 16 errata-xmlrpc 2015-11-19 06:51:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.