Bug 1268122 - openstack-gnocchi packaging is failing
openstack-gnocchi packaging is failing
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi (Show other bugs)
8.0 (Liberty)
Unspecified Linux
unspecified Severity unspecified
: beta
: 8.0 (Liberty)
Assigned To: RHOS Maint
Yurii Prokulevych
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 17:18 EDT by Emilien Macchi
Modified: 2016-04-07 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-gnocchi-1.3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-07 20:53:53 EDT

  None (edit)
Description Emilien Macchi 2015-10-01 17:18:22 EDT
First issue: openstack-gnocchi-common is not automatically installed by openstack-gnocchi-api.


Second issue: impossible to run Gnocchi API:

[root@em-vag-c7-dev ~]# service openstack-gnocchi-api status
Redirecting to /bin/systemctl status  openstack-gnocchi-api.service
openstack-gnocchi-api.service - OpenStack ceilometer API service
   Loaded: loaded (/usr/lib/systemd/system/openstack-gnocchi-api.service; enabled)
   Active: failed (Result: exit-code) since Thu 2015-10-01 20:37:34 UTC; 4s ago
  Process: 14538 ExecStart=/usr/bin/gnocchi-api --logfile /var/log/gnocchi/api.log (code=exited, status=1/FAILURE)
 Main PID: 14538 (code=exited, status=1/FAILURE)

Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: from gnocchi import utils
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: File "/usr/lib/python2.7/site-packages/gnocchi/utils.py", line 20, in <module>
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: from pytimeparse import timeparse
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: File "/usr/lib/python2.7/site-packages/pytimeparse/__init__.py", line 28, in <module>
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: from .timeparse import timeparse as parse
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: File "/usr/lib/python2.7/site-packages/pytimeparse/timeparse.py", line 34, in <module>
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: from builtins import dict, int
Oct 01 20:37:33 em-vag-c7-dev gnocchi-api[14538]: ImportError: No module named builtins
Oct 01 20:37:34 em-vag-c7-dev systemd[1]: openstack-gnocchi-api.service: main process exited, code=exited, status=1/FAILURE
Oct 01 20:37:34 em-vag-c7-dev systemd[1]: Unit openstack-gnocchi-api.service entered failed state.


rpm -qa: http://paste.fedoraproject.org/273851/37342811/
Comment 1 Pradeep Kilambi 2015-10-01 17:47:27 EDT
fix submitted upstream to match 1.2 tag: https://review.gerrithub.io/248840
Comment 2 Alan Pevec 2015-11-04 14:53:20 EST
MODIFIED only when there's build
Comment 3 Alan Pevec 2015-11-04 18:39:01 EST
This should be moved to Product: RDO once openstack-gnocchi component is create there.
Comment 4 Alan Pevec 2015-11-04 19:03:21 EST
Followup patch in -3 was due to missing dep: https://review.gerrithub.io/251426
Comment 6 Jon Schlueter 2015-12-14 10:22:08 EST
Ran yum install on openstack-gnocchi-api and verified it also installed openstack-gnocchi-common
Comment 8 errata-xmlrpc 2016-04-07 17:10:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.