Bug 1268133 - [RFE] RHEV Manager support for SNMPv3 traps
[RFE] RHEV Manager support for SNMPv3 traps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity high
: ovirt-4.0.1
: 4.0.1
Assigned To: Ravi Nori
Jiri Belka
: FutureFeature, ZStream
Depends On:
Blocks: 1348933
  Show dependency treegraph
 
Reported: 2015-10-01 17:35 EDT by Sarvesh Pandit
Modified: 2016-08-23 16:29 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this enhancement, support for SNMP v3 traps was added. RHV-M is now able to provide SNMP v2c and v3 traps. New SNMP related options which can be set along with the default values can be found at: /usr/share/ovirt-engine/services/ovirt-engine-notifier/ovirt-engine-notifier.conf.
Story Points: ---
Clone Of:
: 1348933 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:29:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jbelka: testing_plan_complete+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1978173 None None None Never
oVirt gerrit 57894 master MERGED ovirt-engine-notifier : Add support for SNMPv3 traps 2016-06-21 10:19 EDT
oVirt gerrit 59592 ovirt-engine-4.0 MERGED ovirt-engine-notifier : Add support for SNMPv3 traps 2016-06-22 06:15 EDT
oVirt gerrit 59647 master MERGED engine: Snmp protocols should be read according to security level 2016-06-23 03:03 EDT
oVirt gerrit 59666 ovirt-engine-4.0 MERGED engine: Snmp protocols should be read according to security level 2016-06-24 07:48 EDT

  None (edit)
Description Sarvesh Pandit 2015-10-01 17:35:30 EDT
Description of problem:
Currently, SNMPv2 is the only trap type RHEV-M will send. Request for Enhancement. Add a new feature to RHEV-M. Ability to send SNMPv3 traps in addition to SNMPv2 traps.

Version-Release number of selected component (if applicable):
RHEV 3.5.4

- What is the nature and description of the request?
 
Request for Enhancement. Add a new feature to RHEV-M. Ability to send SNMPv3 traps in addition to SNMPv2 traps.

- Why do you need this? (List the business requirements here)

Customer has security requirements that all SNMP traffic be SNMPv3. At the moment, the RHEV-M system only sends traps via SNMPv2. This is a government contract and this requirement was passed on to us Engineers.
 
 - How would you like to achieve this? (List the functional requirements here)

In a similar way as to how SNMP traps are configured now in RHEV-M, v3.5.4.  https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Administration_Guide/Configuring_the_Red_Hat_Enterprise_Virtualization_Manager_to_Send_SNMP_Traps.html

- Do you have any specific time-line dependencies?

Our timeline need is asap. This program will go live within the next 6 months and the sooner this feature is available, the sooner we can navigate the paperwork for the upgrade approval. 

- List any affected packages or components.

According to the documentation, this appears to be a change to the ovirt-engine-notifier component of RHEV. 

- Would you be able to assist in testing this functionality if implemented?

Yes.
 
- For each functional requirement listed in the previous question, can test to confirm the requirement is successfully implemented.

Not sure I understand this sentence. There is only one functionality requested here and yes, we will test it.
Comment 9 Martin Perina 2016-06-22 06:50:26 EDT
Fixing milestone and flags after cloning
Comment 10 Jiri Belka 2016-07-11 11:57:55 EDT
ok, ovirt-engine-tools-4.0.2-0.2.rc1.el7ev.noarch

tested all SNMPv3 security levels against iReasoning mibbrowser's trap receiver.
Comment 12 errata-xmlrpc 2016-08-23 16:29:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.