Bug 126815 - fam kills system performance
fam kills system performance
Status: CLOSED DUPLICATE of bug 124361
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 14:10 EDT by Sergio
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio 2004-06-27 14:10:36 EDT
Description of problem: Prior to an FC1-->FC2 upgrade, system
performance was very good specifically using PostgreSQL with very
large tables (1.5M+ records). Subseqent to the FC1-->FC2 upgrade there
was a dramatic drop in performance.


Version-Release number of selected component (if applicable): xinetd
2.3.13


How reproducible: Always


Steps to Reproduce:
1. Upgrade from FC1-->FC2
2. Create a large directory with 12,000 png files (by using find to
find all pngs on the system and symbolically linking to them).
3. Use nautilus to browse that directory while the links are being created
4. Run Top and watch fam eat up tons of CPU.

OR

1. Upgrade from FC1-->FC2.
2. Run a PostgreSQL query on a very large table 1.5M+ records.
3. Compare time to FC1 execution.
4. Note the massive drop in performance.

The workaround is to disable fam. Once disabled, performance shoots
back up. I don't know if fam was enabled in FC1 but I'm not going back
to check now that I've finally stabilized FC2.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Schwendt 2004-07-12 14:57:40 EDT

*** This bug has been marked as a duplicate of 124361 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.