Bug 1268159 - _ped.IOException: end of file while reading /dev/sda [NEEDINFO]
_ped.IOException: end of file while reading /dev/sda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8d70a53704fd7ad94752b508020...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 20:06 EDT by Martha
Modified: 2016-04-30 17:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 18:21:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bcl: needinfo? (karasevpa)


Attachments (Terms of Use)
File: anaconda-tb (627.38 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: anaconda.log (27.09 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: environ (614 bytes, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: journalctl (242.07 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: lsblk_output (2.13 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: nmcli_dev_list (1.24 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: program.log (71.38 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: storage.log (239.03 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details
File: ifcfg.log (2.74 KB, text/plain)
2015-10-01 20:06 EDT, Martha
no flags Details

  None (edit)
Description Martha 2015-10-01 20:06:23 EDT
Description of problem:
Installing fedora 23, when start formating hard drive

Version-Release number of selected component:
anaconda-core-23.19.4-1.fc23.i686

The following was filed automatically by anaconda:
anaconda 23.19.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/parted/disk.py", line 212, in commit
    return self.__disk.commit()
  File "/usr/lib/python3.4/site-packages/parted/decorators.py", line 42, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python3.4/site-packages/blivet/formats/disklabel.py", line 253, in commit
    self.partedDisk.commit()
  File "/usr/lib/python3.4/site-packages/blivet/devices/partition.py", line 581, in _create
    self.disk.format.commit()
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 455, in create
    self._create()
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 312, in execute
    self.device.create()
  File "/usr/lib/python3.4/site-packages/blivet/actionlist.py", line 280, in process
    action.execute(callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 380, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1095, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib/python3.4/site-packages/pyanaconda/install.py", line 195, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
_ped.IOException: end of file while reading /dev/sda

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-i686-23_B-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.i686
other involved packages: python3-pyparted-3.10.7-1.fc23.i686, python3-libs-3.4.3-5.fc23.i686, python3-blivet-1.12.4-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Martha 2015-10-01 20:06:35 EDT
Created attachment 1079289 [details]
File: anaconda-tb
Comment 2 Martha 2015-10-01 20:06:36 EDT
Created attachment 1079290 [details]
File: anaconda.log
Comment 3 Martha 2015-10-01 20:06:37 EDT
Created attachment 1079291 [details]
File: environ
Comment 4 Martha 2015-10-01 20:06:44 EDT
Created attachment 1079292 [details]
File: journalctl
Comment 5 Martha 2015-10-01 20:06:45 EDT
Created attachment 1079293 [details]
File: lsblk_output
Comment 6 Martha 2015-10-01 20:06:46 EDT
Created attachment 1079294 [details]
File: nmcli_dev_list
Comment 7 Martha 2015-10-01 20:06:47 EDT
Created attachment 1079295 [details]
File: os_info
Comment 8 Martha 2015-10-01 20:06:50 EDT
Created attachment 1079296 [details]
File: program.log
Comment 9 Martha 2015-10-01 20:06:58 EDT
Created attachment 1079297 [details]
File: storage.log
Comment 10 Martha 2015-10-01 20:06:59 EDT
Created attachment 1079298 [details]
File: ifcfg.log
Comment 11 Brian Lane 2015-10-02 18:21:36 EDT
/dev/sda appears to be failing:


Oct 01 20:02:49 fc7 kernel: ata1.00: exception Emask 0x0 SAct 0xffe00 SErr 0x0 action 0x6 frozen
Oct 01 20:02:49 fc7 kernel: ata1.00: failed command: WRITE FPDMA QUEUED
Oct 01 20:02:49 fc7 kernel: ata1.00: cmd 61/40:48:40:77:04/05:00:00:00:00/40 tag 9 ncq 688128 out
res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Oct 01 20:02:49 fc7 kernel: ata1.00: status: { DRDY }
Oct 01 20:02:49 fc7 kernel: ata1.00: failed command: WRITE FPDMA QUEUED
Oct 01 20:02:49 fc7 kernel: ata1.00: cmd 61/40:50:80:7c:04/05:00:00:00:00/40 tag 10 ncq 688128 out
res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Oct 01 20:02:49 fc7 kernel: ata1.00: status: { DRDY }
Oct 01 20:02:49 fc7 kernel: ata1.00: failed command: WRITE FPDMA QUEUED
Oct 01 20:02:49 fc7 kernel: ata1.00: cmd 61/40:58:c0:81:04/05:00:00:00:00/40 tag 11 ncq 688128 out
Comment 12 Yatin Chawla 2015-12-19 12:01:16 EST
Another user experienced a similar problem:

When I tried to install the fedora xfce spin using a live usb. After selecting the hard disk with automatic configuration it lead to the next screen whete it began to create partitions on the hard drive. During the process of creating the partitions this error occured and asked to quit the progaram. 

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Xfce-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-blivet-1.12.8-1.fc23.noarch, python3-pyparted-3.10.7-1.fc23.x86_64, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.10-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         _ped.IOException: end of file while reading /dev/sda
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 13 menezzal 2016-03-03 05:56:59 EST
Another user experienced a similar problem:

during install...

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=FEDORA-LIVE ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch, python3-pyparted-3.10.7-1.fc23.x86_64
package:        anaconda-core-23.19.10-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         _ped.IOException: Partition(s) 6 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 14 karasevpa 2016-03-17 13:28:14 EDT
Another user experienced a similar problem:

installing to hpzbook with SSD + sata drive 1TB. 

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-pyparted-3.10.7-1.fc23.x86_64, python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
package:        anaconda-core-23.19.10-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         _ped.IOException: end of file while reading /dev/sdb
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 15 Brian Lane 2016-03-17 20:24:03 EDT
(In reply to karasevpa from comment #14)
> Another user experienced a similar problem:
> 
> installing to hpzbook with SSD + sata drive 1TB. 
> 
> cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst
> --method=livecd:///dev/mapper/live-base
> cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img
> root=live:CDLABEL=Fedora-Live-WS-x86_64-23-10 rootfstype=auto ro
> rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
> hashmarkername: anaconda
> kernel:         4.2.3-300.fc23.x86_64
> other involved packages: python3-pyparted-3.10.7-1.fc23.x86_64,
> python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
> package:        anaconda-core-23.19.10-1.fc23.x86_64
> packaging.log:  
> product:        Fedora
> reason:         _ped.IOException: end of file while reading /dev/sdb
> release:        Fedora release 23 (Twenty Three)
> version:        23

Check your logs for errors similar to those in comment 11, if everything looks ok please attach the installation logs from /tmp/*log to a new bug.
Comment 16 Diego Herera A. 2016-04-30 17:09:22 EDT
Another user experienced a similar problem:

Estaba instalando Fedora y solo metí la contraseña de Root, luego se pegó, esto no pasó con el spin de Cinnamon

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-blivet-1.12.8-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64, python3-pyparted-3.10.7-1.fc23.x86_64
package:        anaconda-core-23.19.10-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         _ped.IOException: Partition(s) 5 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
release:        Fedora release 23 (Twenty Three)
version:        23

Note You need to log in before you can comment on or make changes to this bug.