Bug 1268176 - xen qemu binaries no longer live in %_libdir, breaks libvirt Xen VMs
xen qemu binaries no longer live in %_libdir, breaks libvirt Xen VMs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 21:54 EDT by Adam Williamson
Modified: 2015-10-23 13:21 EDT (History)
13 users (show)

See Also:
Fixed In Version: xen-4.5.1-11.fc23 xen-4.5.1-13.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 13:21:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-10-01 21:54:12 EDT
At least on Fedora, xen's qemu binaries now always live in /usr/lib/xen/bin (even on x86_64). Per the package changelog this was changed in 4.5.0-1, in January.

Existing Xen VMs on x86_64 Fedora are now broken (because they look in /usr/lib64) and you can't create a new one (because it looks in /usr/lib64).

This is affecting at least F22 and F23.

Patch should be something like:

diff --git a/src/xen/xen_hypervisor.c b/src/xen/xen_hypervisor.c
index 431c47a..e7fff85 100644
--- a/src/xen/xen_hypervisor.c
+++ b/src/xen/xen_hypervisor.c
@@ -2144,9 +2144,7 @@ xenHypervisorBuildCapabilities(virConnectPtr conn, virArch hostarch,
         if ((guest = virCapabilitiesAddGuest(caps,
                                              guest_archs[i].hvm ? VIR_DOMAIN_OSTYPE_HVM : VIR_DOMAIN_OSTYPE_XEN,
                                              guest_archs[i].arch,
-                                             (hostarch == VIR_ARCH_X86_64 ?
-                                              "/usr/lib64/xen/bin/qemu-dm" :
-                                              "/usr/lib/xen/bin/qemu-dm"),
+                                             "/usr/lib/xen/bin/qemu-dm",
                                              (guest_archs[i].hvm ?
                                               "/usr/lib/xen/boot/hvmloader" :
                                               NULL),

if we don't get Xen to move the binaries back.
Comment 1 Cole Robinson 2015-10-05 20:46:15 EDT
Yeah I think the xen package needs to add symlinks at least, since otherwise there's no way to fix pre-existing VMs which have the lib64 path in their XML.
Comment 2 Fedora Update System 2015-10-07 17:22:38 EDT
xen-4.5.1-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7bb70880ca
Comment 3 Fedora Update System 2015-10-08 06:30:40 EDT
xen-4.5.1-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xen'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7bb70880ca
Comment 4 Fedora Update System 2015-10-09 11:31:38 EDT
xen-4.5.1-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-10-13 12:31:18 EDT
xen-4.5.1-13.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fca1900745
Comment 6 Fedora Update System 2015-10-14 05:27:33 EDT
xen-4.5.1-13.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xen'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fca1900745
Comment 7 Fedora Update System 2015-10-23 13:21:23 EDT
xen-4.5.1-13.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.