Bug 1268186 - [GSS](6.4.z) ManagedSocketFactory doesn't work for client sockets
[GSS](6.4.z) ManagedSocketFactory doesn't work for client sockets
Status: CLOSED DUPLICATE of bug 1268185
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.4.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Enrique Gonzalez Martinez
Jitka Kozana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 23:38 EDT by dereed
Modified: 2015-10-30 03:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 22:35:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFCORE-1029 Major Resolved ManagedSocketFactory doesn't work for client sockets 2016-05-23 03:46 EDT

  None (edit)
Description dereed 2015-10-01 23:38:45 EDT
SocketBindingManagerImpl does not work with client sockets.

It adds sockets to a map based on local address. Client sockets that have not been bound yet do not have a local address.

This breaks the JGroups subsystem's ManagedSocketFactory, which uses SocketBindingManagerImpl for both server and client sockets.
Comment 1 dereed 2015-10-01 23:41:31 EDT
Fixing this is dependent on how BZ 1268185 is fixed.

(If the custom socket factory is removed, this won't be necessary in 6.4.z.  If BZ 1268185 fixes the socket factory so it's set correctly, this is required).
Comment 2 dereed 2015-10-22 22:35:31 EDT
The PR for BZ 1268185 makes this no longer an issue.
(the calls from ManagedSocketFactory to SocketBindingManagerImpl that trigger the issue were removed).
Comment 3 Enrique Gonzalez Martinez 2015-10-23 02:40:31 EDT
This bug is fixed with BZ 1268185 so this should be closed as duplicate.

*** This bug has been marked as a duplicate of bug 1268185 ***

Note You need to log in before you can comment on or make changes to this bug.