Bug 1268192 - Rsync fails with "Corrupted MAC on input. Disconnecting: Packet corrupt"
Rsync fails with "Corrupted MAC on input. Disconnecting: Packet corrupt"
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 01:27 EDT by Kyle
Modified: 2015-10-05 06:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 06:38:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle 2015-10-02 01:27:49 EDT
Description of problem:
copr builds are building successfully, but the final rsync fails with an error message.

Version-Release number of selected component (if applicable):


How reproducible:
Random, occurred twice on Fedora Rawhide, once on EPEL 7, but I only did 5 builds.

Steps to Reproduce:
1. Start a copr build, possibly only on EPEL7/Fedora Rawhide
2. Wait
3. Build might be marked as failed despite rpm packages being in the fold afterwards.

Actual results:
Some copr builds fail inexplicably in the middle of an rsync job.

Expected results:
Rsync is successful

Additional info:
Affected builds:
https://copr-be.cloud.fedoraproject.org/results/kyl191/nginx-pagespeed/fedora-rawhide-x86_64/00122195-nginx-pagespeed/build-00122195.rsync.log

https://copr-be.cloud.fedoraproject.org/results/kyl191/nginx-pagespeed/epel-7-x86_64/00122218-nginx-pagespeed/build-00122218.rsync.log

https://copr-be.cloud.fedoraproject.org/results/kyl191/nginx-pagespeed/fedora-rawhide-i386/00122219-nginx-pagespeed/build-00122219.rsync.log
Comment 1 Miroslav Suchý 2015-10-05 06:38:19 EDT
This seems to be cause by some issues in libvirt network card driver.
I followed
  https://www.rdoproject.org/Using_GRE_tenant_networks#Offloading
and disabled offloading on frontend, backend and builders.
Hopefully (as I can not reproduce it deterministic) it resolve this issue.

If you ever hit it again, please reopen this BZ.

Note You need to log in before you can comment on or make changes to this bug.