Bug 1268196 - remove glamor support from nouveau ddx
remove glamor support from nouveau ddx
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
7.2
All Linux
unspecified Severity high
: rc
: 7.2
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 01:45 EDT by Ben Skeggs
Modified: 2015-11-18 23:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 23:27:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Skeggs 2015-10-02 01:45:51 EDT
The codepaths necessary to support Glamor acceleration in xorg-x11-drv-nouveau, as required to support all NVIDIA GPUs beginning from GM10x, have bit-rotted and no longer function correctly.  The result is the X server crashing when attempting to log in from GDM.

Upstream Nouveau no longer supports Glamor acceleration, instead it causes the X server to fall back to the built-in "modesetting" driver, which provides identical functionality.

This bug is to backport those patches from upstream, in order to fix the crashes that occur with the current packages present in 7.2.
Comment 3 Tomas Pelka 2015-10-02 08:11:40 EDT
Can this fix affect also other chipsets than maxwell?
Comment 4 Ben Skeggs 2015-10-02 18:01:03 EDT
Older chipsets are using EXA by default (we have no EXA implementation for Maxwell, Glamor was deemed a better choice), which does not have the mentioned issues.
Comment 10 errata-xmlrpc 2015-11-18 23:27:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html

Note You need to log in before you can comment on or make changes to this bug.