Bug 126821 - glxgears crashes alleging "SIS driver : out of video memory"
glxgears crashes alleging "SIS driver : out of video memory"
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2004-06-27 18:18 EDT by Rodrigo Vieira Couto
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-30 18:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
glxinfo output (3.00 KB, text/plain)
2004-06-27 18:19 EDT, Rodrigo Vieira Couto
no flags Details
xorg.conf (2.67 KB, text/plain)
2004-06-27 18:19 EDT, Rodrigo Vieira Couto
no flags Details
Xorg.0.log (32.91 KB, text/plain)
2004-06-28 23:07 EDT, Rodrigo Vieira Couto
no flags Details
A screenshot with the above described situation. (151.82 KB, text/plain)
2004-07-09 16:19 EDT, Rodrigo Vieira Couto
no flags Details

  None (edit)
Description Rodrigo Vieira Couto 2004-06-27 18:18:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I run glxgears and other openGL screensavers, they promptly die
with this error message:

[rodrigo@localhost rodrigo]$ glxgears
SIS driver : out of video memory
Fatal errors in sis_dri.so

My xorg.conf and glxinfo output will be attached.

hwbrowser shows that my video board is:

630/730 PCI/AGP VGA Display Adapter
Silicon Integrated System [SiS]
Card: SiS 630

[rodrigo@localhost rodrigo]$ uname -a
Linux localhost.localdomain 2.6.6-1.435 #1 Mon Jun 14 09:09:07 EDT
2004 i686 athlon i386 GNU/Linux

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run glxgears

Actual Results:  This error message:
SIS driver : out of video memory
Fatal errors in sis_dri.so

Expected Results:  It should have run glxgears.

Additional info:
Comment 1 Rodrigo Vieira Couto 2004-06-27 18:19:20 EDT
Created attachment 101455 [details]
glxinfo output
Comment 2 Rodrigo Vieira Couto 2004-06-27 18:19:53 EDT
Created attachment 101456 [details]
Comment 3 Rodrigo Vieira Couto 2004-06-28 22:40:05 EDT
I tried to partialy follow this page's instructions but with no success:

http://www.winischhofer.net/sisdri.shtml (Variant 3)

I set my video memory to 32M on the BIOS setup and added

        Option      "MaxXFBMem" "12288"

to my "Device" section on xorg.conf.

When I run glxgear, tuxracer, etc, I get a blank window with some
random polygons appearing from the left-top corner.
Comment 4 Rodrigo Vieira Couto 2004-06-28 23:07:18 EDT
Created attachment 101497 [details]
Comment 5 Rodrigo Vieira Couto 2004-06-28 23:58:40 EDT
More people complaining about this problem on the [dri-users] mailing


The [dri-users] are kept on
Comment 6 Rodrigo Vieira Couto 2004-07-09 16:19:49 EDT
Created attachment 101771 [details]
A screenshot with the above described situation.
Comment 10 Alan Cox 2004-07-10 09:18:16 EDT
Eric Anholt ressurected SiS DRI for Xorg/XFree86 4.4. 

For a lot of cases you need the sisfb module loaded as well as the X
Comment 11 Rodrigo Vieira Couto 2004-07-10 09:20:51 EDT
I've found an article that describes this same problem (sorry, Spanish):


Basicly, they suggest applying a patch to the Xfree 4.4 src tree and
recompiling. I suppose it shouldn't be too different compared with
Xorg 6.7. However, this patch seems to be corrupted, so I have
contacted them  about it. I am waiting a reply.
Comment 12 Rodrigo Vieira Couto 2004-07-10 09:33:03 EDT
From Winischhofer site: (http://www.winischhofer.net/sisdri.shtml)

Variant 3 [Linux and *BSD]: I want to use X with DRI but I don't
want/have sisfb.

    * You need Linux kernel 2.6.3 or later, or *BSD with a current
(2004) SiS DRM driver.
    * SiS 540/630/730: Set the video memory in the BIOS setup to at
least 32MB (better yet 64MB).
    * Linux only: Do not enable or compile sisfb, neither as a module
nor into the kernel.
    * Enable SiS DRM support in the kernel configuration. Choose the
SiS DRM to be compiled as a module (not statically into the kernel).
The module will be loaded automatically, no need to modprobe it.
    * Enable AGP support in your kernel configuration (not for PCI
versions of SIS 300/305 cards). It is recommended to compile AGP
statically into the kernel. Note: The AGP driver to use depends on
what host chipset you have. On SiS 630/730 and assumingly 540, this is
"SiS generic". If you use a SiS 300/305 (AGP) in a non-SiS mainboard,
check the manufacturer of your AGP host controller.
    * Recompile and install the kernel and the modules
    * Download and install the latest XFree86 driver (sis_drv.o) for
your version of XFree86.
    * Add the Option "MaxXFBMem" "12288" to the Device section of your
XFree86 config file (in most cases /etc/X11/XF86Config or
/etc/X11/XF86Config-4 or /etc/X11/Xorg.conf).
    * That's it!
Comment 13 Rodrigo Vieira Couto 2004-07-10 09:36:56 EDT
I've followed this troubleshooting guide from DRI homepage
Everything was correct, except the animation itself :)
Comment 14 Matt Prazak 2004-07-11 12:39:36 EDT
Just this past week, I had all the same problems outlined above with
XFree86, OpenGL, and my SiS630-based graphics.  The one thing that
made all the difference was replacing the DRI driver for XFree86
(http://www.winischhofer.net/sis/sis_dri.so.gz).  However, I replaced
this file after replacing the sisfb driver in the kernel and replacing
the SiS driver, sis_drv.o, in XFree86 (also using those provided at
www.winischhofer.net), so I can't guarantee that just replacing
sis_dri.so will fix it.  Regardless, I would recommend replacing
everything, anyway, as the replacement drivers were all better than
those released with XFree86, even, which I am using.
Comment 15 Matt Prazak 2004-07-11 12:54:12 EDT
I should add that I basically did everything else recommended at
www.winischhofer.net, such as tweaking MaxXFBMem to get rid of the
out-of-memory errors, before finally finding that replacing sis_dri.so
fixed glxgears 100%.  Also, my kernel version is 2.4.18.  I highly
recommend following every instruction at www.winischhofer.net, as
there is just a lot of stuff there I would have never thought of.
Comment 16 Rodrigo Vieira Couto 2004-07-11 18:14:35 EDT
Thanks Matt. That worked. I downloaded the sis_drv.so from
www.winischhofer.net and everything worked out.
Comment 17 Alan Cox 2004-07-11 18:27:51 EDT
Good to hear. I'm playing with the CVS Xorg at the moment and that has
a very recent SiS driver from Thomas merged.
Comment 18 Adrien Parker 2004-07-29 20:57:23 EDT
hi Matt Prazak, where I have to put sis_dri.so ? I don't understand,
me too I have the same problem with my sis305.
Comment 19 Matt Prazak 2004-08-03 13:06:24 EDT
The files on my system relevant to the SiS graphics are:

plus the compiled-in kernel SiS driver

Since the top two are dynamically-loaded modules, you can back up your
current files, drop in the new ones, and restart your X server.  Try
replacing sis_dri.so first to see if simply doing that will fix your

Also, the information at www.winischhofer.net should help you
determine if the fix discussed above for the SiS630 applies to the
SiS305 (there appear to be a couple or three "families" of SiS chip
model numbers).

Comment 20 Mike A. Harris 2004-08-30 18:12:04 EDT
I'm going to assume for now that the current Xorg-x11-
in rawhide has recent sis code which may fix this problem, and
close the issue as "RAWHIDE".  If the current rawhide X does not
fix this (I dont have any SiS hardware to find out), please open
a bug in X.Org bugzilla at http://bugs.freedesktop.org so the
issue can be tracked more closely by the X Developers and SiS
driver maintainer himself.  Should that be needed, you can paste
the upstream bug report URL here if you'd like us to also track
the issue in the upstream bugzilla.

Thanks in advance for testing the rawhide X.

Note You need to log in before you can comment on or make changes to this bug.