Bug 1268244 - All l3 agents go to standby ha_state after restarting haproxy resource triggered by incomplete cleanup.
All l3 agents go to standby ha_state after restarting haproxy resource trigge...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity high
: z3
: 7.0 (Kilo)
Assigned To: Miguel Angel Ajo
Toni Freger
: Triaged, ZStream
Depends On: 1266910
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 05:30 EDT by Miguel Angel Ajo
Modified: 2016-09-15 07:42 EDT (History)
22 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.1-12.el7ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, the netns pacemaker OCF resource did not perform a full cleanup of the neutron netns services. As a result, some of those services were orphaned, and were never restored by they l3-agent because were seen as running, but were actually disconnected. This update addresses this by adding the missing cleanup steps to the netns cleanup OCF resource.
Story Points: ---
Clone Of: 1266910
Environment:
Last Closed: 2015-12-21 11:58:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 248891 None None None Never

  None (edit)
Comment 4 Toni Freger 2015-12-09 05:35:42 EST
Verified with virt env. installed with OSP-d 
3-Controllers - HA
1-Ceph
1-Compute

openstack-tripleo-common-0.0.1.dev6-5.git49b57eb.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-87.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch

openstack-neutron-2015.1.2-2.el7ost.noarch


Steps to Reproduce (tested several times):
1. Deploy overcloud with 3 controllers 
2. Create tenant network, external network and router
3. Run pcs resource restart haproxy-clone on one of the controllers
4. Check l3 agents for the router 
5. Router external connectivity tested 
6. Router fail-over triggered and different l3 agent become an active. 
7. Router external connectivity tested
Comment 6 errata-xmlrpc 2015-12-21 11:58:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2652

Note You need to log in before you can comment on or make changes to this bug.