Bug 1268252 - Adding additional compute node after running 'overcloud update stack' fails
Adding additional compute node after running 'overcloud update stack' fails
Status: CLOSED DUPLICATE of bug 1267558
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 06:01 EDT by Marius Cornea
Modified: 2016-04-18 02:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 07:40:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed stack update (3.35 KB, text/plain)
2015-10-02 06:01 EDT, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-10-02 06:01:41 EDT
Created attachment 1079403 [details]
failed stack update

Description of problem:
I am trying to add an additional compute node to an overcloud where I've previously run 'openstack overcloud update stack' and the stack-update seems to eventually timeout and the heat stack ends up with UPDATE_FAILED status. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run initial deployment:

openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml --control-scale 3 --compute-scale 1 --ntp-server 10.5.26.10 --libvirt-type qemu  -e ~/templates/firstboot-environment.yaml

2. Run packages update:
openstack overcloud update stack --templates ~/templates/my-overcloud -i overcloud

3. Try to add aditional compute
openstack overcloud deploy --templates ~/templates/my-overcloud --control-scale 3 --compute-scale 2 --ntp-server 10.5.26.10 --libvirt-type qemu 

Actual results:
The additional node gets provisioned but the stack update gets stuck and it eventually fails. 

Expected results:
The stack successfully gets updated and the additional compute node is ready to use.   

Additional info:
Attaching output of heat resource-list  and heat stack-list.
Comment 2 Jan Provaznik 2015-10-02 07:40:03 EDT

*** This bug has been marked as a duplicate of bug 1267558 ***

Note You need to log in before you can comment on or make changes to this bug.