Bug 1268255 - Tab switching keys are not passed through for tabless windows
Summary: Tab switching keys are not passed through for tabless windows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-terminal
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-02 10:14 UTC by Petr Šplíchal
Modified: 2016-06-01 01:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 09:02:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 730128 0 Normal RESOLVED Tab switching keys are not passed through for tabless windows 2020-12-08 03:20:25 UTC
Red Hat Product Errata RHBA-2015:2243 0 normal SHIPPED_LIVE gnome-terminal bug fix and enhancement update 2015-11-19 09:11:39 UTC

Description Petr Šplíchal 2015-10-02 10:14:52 UTC
Description of problem:

It seems that the keyboard shortcuts Ctrl-PageUp and Ctrl-PageDown
are now caught by gnome-terminal even if there is a single tab
open. This prevents using the very same shortcuts in applications
running in the terminal, e.g. switching between tabs in Vim.

Version-Release number of selected component (if applicable):
gnome-terminal-3.14.3-1.el7.x86_64

Steps to Reproduce:
1. open gnome-terminal window
2. vim -p one two three
3. ctrl-page-down

Actual results:
Nothing happens.

Expected results:
Vim jumps to the second tab.

Additional info:
This worked fine with gnome-terminal-3.8.4-8.el7.x86_64

Comment 3 Debarshi Ray 2015-10-05 15:01:42 UTC
This is a consequence of:

commit a319aeb66f36e728af1b4929ddd69574df838702
Author: Christian Persch <chpe@gnome.org>
Date:   Sun May 12 22:26:03 2013 +0200

    accels: Port accelerators to use GtkApplication
    
    Add GActions for the window actions, and use these as targets for the
    accelerators.
    
    Conflicts:
        src/terminal-accels.c
        src/terminal-window.c

Comment 4 Debarshi Ray 2015-10-05 18:27:59 UTC
(In reply to Petr Šplíchal from comment #0)
> It seems that the keyboard shortcuts Ctrl-PageUp and Ctrl-PageDown
> are now caught by gnome-terminal even if there is a single tab
> open. This prevents using the very same shortcuts in applications
> running in the terminal, e.g. switching between tabs in Vim.

To test:

a) Open 2 files in vim as:
  $ vim -p file1 file2
   ... and try to use ctrl+page-up/down to move between the tabs

b) Connect to a IRC network using irssi and join two channels:
  $ irssi
  /join #fedora-devel
   ... and try to switch between the channels using alt+1 and alt+2.

Comment 5 Debarshi Ray 2015-10-05 18:49:08 UTC
This will be part of gnome-terminal-3.14.3-3.el7 once I manage to build it after playing the tagging game.

Comment 10 Petr Šplíchal 2015-10-07 14:08:39 UTC
Great! I confirm this is working fine with the latest package.
Thanks for quickly fixing the regression.

Comment 11 errata-xmlrpc 2015-11-19 09:02:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2243.html


Note You need to log in before you can comment on or make changes to this bug.