Bug 1268258 - mongodb fails to start with numa interleave policy on RHEL7.1
mongodb fails to start with numa interleave policy on RHEL7.1
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.1.1
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 06:33 EDT by Pradeep Kumar Surisetty
Modified: 2017-08-11 08:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 08:30:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kumar Surisetty 2015-10-02 06:33:07 EDT
Description of problem:

mongodb recommends to interleave memory across all nodes for better performance.  As part of this exercise, i tried to interleave mongodb and check satellite performance. Mongodb fails to start with NUMA interleave. 

http://docs.mongodb.org/manual/administration/production-notes/


1) interleave across nodes for mongod: 

numactl --interleave=all /usr/bin/mongod -f /etc/mongodb.conf


NUMA is interleaving across nodes as shown below. 


http://pastebin.test.redhat.com/316482

2) Start mongod. It fails to start. 

systemctl start mongod.service. 

Strace:

http://pastebin.test.redhat.com/316531

Its an issue with systemd.   

3) Added init.d script for mongod. Still fails to start.  

http://pastebin.test.redhat.com/317072

Without interleave, mongod starts successfully. 


Version-Release number of selected component (if applicable):

mongodb-2.4.9-3.el7sat.x86_64
katello-2.2.0.16-1.el7sat.noarch
pulp-server-2.6.0.15-1.el7sat.noarch

How reproducible:


Steps to Reproduce:
1.  numactl --interleave=all /usr/bin/mongod -f /etc/mongodb.conf    
2.   systemctl start mongod.service

Actual results:

Mongod fails to start. 

Expected results:

Mongod should start after numa interleave



Additional info:
Comment 2 Pradeep Kumar Surisetty 2016-01-20 07:02:46 EST
Ran mongodb with numa interleave on centos/ 
Not sure if this is the recommended one. 

http://psuriset.com/2015/12/20/starting-mongodb-on-centos-with-numa-disabled
Comment 3 Eric Helms 2016-12-16 11:47:10 EST
Can you shed some light on what you believe the issue is? i.e. Do you believe it the issue is in the version of MongoDB we ship? The packaging around the MongoDB that we ship? An issue with systemd in general?
Comment 4 Pradeep Kumar Surisetty 2017-04-24 07:24:08 EDT
i believe its with mongodb we ship.
Comment 5 Bryan Kearney 2017-08-11 08:30:25 EDT
This bz has been moved to an upstream issue. We will no longer be tracking this in the downstream. When the upstream issue is fixed, the next release of Satellite will include the fix. If this is a concern, please reach out to Bryan Kearney or Rich Jerrido. Thank you.

Note You need to log in before you can comment on or make changes to this bug.