Bug 1268298 - Users in user portal can't assign vNIC profiles in spite of having VnicProfileUser permission
Users in user portal can't assign vNIC profiles in spite of having VnicProfil...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.2
: ---
Assigned To: Alona Kaplan
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 09:13 EDT by David Jaša
Modified: 2016-02-10 14:16 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-03 06:45:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
pm-rhel: blocker?
rule-engine: planning_ack?
djasa: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
UP exception and API example (3.42 KB, text/plain)
2015-10-02 09:13 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2015-10-02 09:13:25 EDT
Created attachment 1079434 [details]
UP exception and API example

Description of problem:
Users in user portal can't assign vNIC profiles in spite of having VnicProfileUser permission

Version-Release number of selected component (if applicable):
3.6.0-15 / rhevm-backend-3.6.0-0.18.el6.noarch

How reproducible:
always on my setup

Steps to Reproduce:
1. create a separate VM network, make sure that Everyone has
    VnicProfileUser permission
2. as a power user, add a nic with <empty> vnic profile to the VM
3. try to assign the network profile to the VM

Actual results:
  * userportal:
    * "SEVERE: Uncaught exception" in Error Console on open of Edit NIC dialog
    * Profile is empty, as is it's drop-down menu
    * Type, Custom MAC address and Link state are disabled
  * filtered API returns "detail" : "Network not found in cluster"

Expected results:
Users are able to assign profiles as in previous 3.6 builds & releases (such as 3.5 --> Regression)

Additional info:
*
Comment 3 Alona Kaplan 2015-10-07 12:56:45 EDT
1. David, you wrote- "Users in user portal can't assign vNIC profiles in spite of having VnicProfileUser permission".
Do you mean the current user/everyone has VnicProfileUser role on the selected profile?
Can you please attach a screenshot of the webadmin->configure dialog, when VnicProfileUser is selected.

2. Also attach a screenshot of the edit vnic dialog- with the vnic profiles list opened.

3. Try to add a new vnic profile to the desired network, make sure the "Allow all users to use this Profile" checkbox of the profile is checked.
Do you manage to assign this new profile to the vnic?

4. Please attach the engine logs to the bug.
Comment 4 David Jaša 2015-10-08 07:31:16 EDT
REST API part of the bug is gone, I can successfully:
  * create a nic: empty or with network or with vnic_profile specified
  * update a network-/profileless nic with either a network or a profile

So the issue is now only in User Portal (whose behaviour didn't change) as of versions:e
rhevm-backend-3.6.0-0.18.el6.noarch
rhevm-userportal-3.6.0-0.18.el6.noarch
rhevm-webadmin-portal-3.6.0-0.18.el6.noarch
rhevm-restapi-3.6.0-0.18.el6.noarch
Comment 5 Barak 2015-10-08 09:02:50 EDT
this happens only on the reporter's environment and we can't reproduce it.
Hence moving to 3.6.1
Comment 7 Alona Kaplan 2015-11-18 03:37:06 EST
I cannot reproduce the bug.

David, is it still reproducible on your environment?

Meni, can your team try to reproduce it?
Comment 8 Michael Burman 2015-11-18 04:56:17 EST
Hi Alona, David

I can't reproduce this report on  3.6.0.3-0.1.el6
Comment 9 David Jaša 2015-11-18 08:38:41 EST
(In reply to Alona Kaplan from comment #7)
> I cannot reproduce the bug.
> 
> David, is it still reproducible on your environment?
> 

Yes, it is. I can't choose even <Empty> profile for new NICs. The environment is upgraded to latest build (3.6.0-20) with these versions:
rhevm-backend-3.6.0.3-0.1.el6.noarch
rhevm-webadmin-portal-3.6.0.3-0.1.el6.noarch
rhevm-userportal-3.6.0.3-0.1.el6.noarch
Comment 10 Alona Kaplan 2015-11-19 03:25:21 EST
Since we cannot reproduce it I'm moving it to 3.6.2.
David, please check if it is still happening in 3.6.1.
Comment 12 David Jaša 2015-12-23 13:12:18 EST
Update: in 3.6.2-2 build (rhevm-backend-3.6.2-0.1.el6.noarch), granting VnicProfile to Everyone on logical network made things work, even after removal of that permission. Now all the profiles created with "Public" or "Allow all users to use this Profile" are available for choice.

I'd close as CURRENTRELEASE if new installs are not affected (as comments #c7, #c8 and #c10 suggest).

Note You need to log in before you can comment on or make changes to this bug.