Bug 1268332 - VPN connects but issues with visiting Websites
VPN connects but issues with visiting Websites
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 10:35 EDT by tolga.malachi
Modified: 2015-10-06 11:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 11:22:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt of journalctl after disabling and enabling VPN Connection (14.51 KB, text/plain)
2015-10-02 10:35 EDT, tolga.malachi
no flags Details

  None (edit)
Description tolga.malachi 2015-10-02 10:35:23 EDT
Created attachment 1079464 [details]
Excerpt of journalctl after disabling and enabling VPN Connection

Description of problem:
It is like i have no internet. No websites are loading in Google Chrome if my openconnect VPN is enabled. In Firefox i can actually visit google. But no
other website including those websites (bugtracker, gitlab) in the VPN. 

But i can curl and ping any websites. It is like there is a name resolving issue?


Version-Release number of selected component (if applicable):
NetworkManager               x86_64     1:1.0.6-5.fc22



How reproducible:


Steps to Reproduce:
1. Enable an openconnect VPN
2. Try to visit any website (except google with FireFox Browser, this works for me)


Actual results:
Browser tries to load the website but can't.


Expected results:
The content of the website.

Additional info:
This Fedora 22 installation is quite new. End of August if i remember correct. The VPN actually worked some time ago (like 2 weeks ago?).
I tried different options like maybe something wrong with the firewall? But since i didn't touch the firewall it couldn't.
So i made a:
sudo dnf downgrade NetworkManager --allowerasing

And DNF downgraded the following packages:
Downgrading:
 NetworkManager                                                x86_64                                      1:1.0.2-1.fc22
 NetworkManager-adsl                                           x86_64                                      1:1.0.2-1.fc22
 NetworkManager-bluetooth                                      x86_64                                      1:1.0.2-1.fc22
 NetworkManager-libnm                                          x86_64                                      1:1.0.2-1.fc22
 NetworkManager-team                                           x86_64                                      1:1.0.2-1.fc22
 NetworkManager-wifi                                           x86_64                                      1:1.0.2-1.fc22
 NetworkManager-wwan                                           x86_64                                      1:1.0.2-1.fc22

And after a restart everything worked fine. Since there is no downgraded openconnect package i guess something is wrong
with NetworkManager Package itself?
This is my first bug report and i hope i provided enough informations to you.
Comment 1 Jirka Klimes 2015-10-06 09:22:20 EDT
There was a fix for VPN MTU in NetworkManager-1.0.6-6.fc22 - bug 1244547.

Please update to that package and report if it fixes your issues.
Comment 2 tolga.malachi 2015-10-06 11:18:51 EDT
Yes. The update fixed my problem, too. I actually read the bugreport before i posted mine but didn't expect it would be the same problem.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.