Bug 126835 - ld cannot find -lselinux when compiling KDE apps
ld cannot find -lselinux when compiling KDE apps
Status: CLOSED DUPLICATE of bug 121764
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 23:46 EDT by Steve
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2004-06-27 23:46:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
I seem to have a problem compiling certain KDE programs in FC2.  Just
now I've tried to compile amarok and during the make, I get this error
message:  /usr/bin/ld: cannot find -lselinux

I get this exact same error when I tried to compile komba2 before too. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download amarok 1.0 source code
2. Run configure as shown in the README
3.
    

Actual Results:  You get the obscure error:  /usr/bin/ld: cannot find
-lselinux

Expected Results:  Should be no error since this app has nothing to do
with selinux

Additional info:

A friend of mine compiled amarok in Mandrake 10 and had no problems. 
So how come there are reference to selinux?  selinux is disabled on my
system (as per default).

I dunno which component to put this in but I think it is serious
enough to warrant some attention.
Comment 1 Steve 2004-06-27 23:47:32 EDT
This is the make message below.  Notice there is no -lselinux anywhere
in the command but I still get this error message

/bin/sh ../../libtool --silent --mode=link --tag=CXX g++ 
-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W
-Wpointer-arith -Wwrite-strings -O2 -Wformat-security
-Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common
-DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT
-DQT_NO_TRANSLATION    -o amarokapp -L/usr/X11R6/lib
-L/usr/lib/qt-3.3/lib -L/usr/lib  -R /usr/lib -R /usr/lib/qt-3.3/lib
-R /usr/X11R6/lib actionclasses.o amarokfilelist.o app.o browserbar.o
collectionbrowser.o collectiondb.o configdialog.o contextbrowser.o
coverfetcher.o directorylist.o effectwidget.o enginecontroller.o
engineobserver.o fht.o filebrowser.o kbookmarkhandler.o metabundle.o
osd.o playerwindow.o playlist.o playlistbrowser.o playlistitem.o
playlistloader.o playlistwindow.o pluginmanager.o searchbrowser.o
sliderwidget.o socketserver.o statusbar.o streambrowser.o systray.o
threadweaver.o tracktooltip.o welcomebrowser.o Options1.o Options2.o
Options3.o Options4.o Options5.o amazonsetup.o directorylistbase.o
../../amarok/src/amarokcore/libamarokcore.la
../../amarok/src/analyzers/libanalyzers.la
../../amarok/src/engine/libengine.la
../../amarok/src/plugin/libplugin.la
../../amarok/src/sqlite/libsqlite.la
../../amarok/src/titleproxy/libtitleproxy.la -lkutils -lkio -lkdeui
-lkdecore -lkhtml -L/usr/lib -ltag -lGL
/usr/bin/ld: cannot find -lselinux
collect2: ld returned 1 exit status
make[4]: *** [amarokapp] Error 1
Comment 2 Steve 2004-06-28 01:42:04 EDT

*** This bug has been marked as a duplicate of 121764 ***
Comment 3 Ngo Than 2004-06-28 06:38:50 EDT
The problem is that kdelibs was built with fam support. The fam
library has built with libselinux also. If you take a look a .la files
(for example /usr/lib/libkdio.la) you will see libselinux is needed by
linken
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.