Bug 1268483 - Organization creation wizard generates a Foreman Exception
Organization creation wizard generates a Foreman Exception
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Unspecified
x86_64 Linux
unspecified Severity urgent (vote)
: 6.1.3
: --
Assigned To: Katello Bug Bin
Og Maciel
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 17:38 EDT by Og Maciel
Modified: 2017-02-23 14:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 14:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stacktrace screenshot (150.80 KB, image/png)
2015-10-02 17:40 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2015-10-02 17:38:28 EDT
Description of problem:

Creating a new organization as the 'admin' user fails with ERF42-5434 [Foreman::Exception]: unknown permission view_config_templates

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. As the admin user, create a new organization
2. During the creation wizard, click the 'Proceed to Edit'
3.

Actual results:

A stacktrace is displayed

Expected results:


Additional info:

Foreman::Exception
ERF42-5434 [Foreman::Exception]: unknown permission view_config_templates
app/services/association_authorizer.rb:21:in `view_permission_name'
app/services/association_authorizer.rb:9:in `authorized_associations'
app/helpers/layout_helper.rb:88:in `multiple_selects'
app/views/taxonomies/_form.html.erb:144:in `block in _app_views_taxonomies__form_html_erb___1433964276212543786_140179700'
app/helpers/layout_helper.rb:307:in `form_for'
app/views/taxonomies/_form.html.erb:3:in `_app_views_taxonomies__form_html_erb___1433964276212543786_140179700'
app/views/taxonomies/edit.html.erb:4:in `_app_views_taxonomies_edit_html_erb___3375171378674763924_123649080'
app/controllers/concerns/foreman/controller/taxonomies_controller.rb:67:in `block in edit'
app/models/taxonomy.rb:58:in `block in no_taxonomy_scope'
app/models/taxonomy.rb:65:in `block (2 levels) in as_taxonomy'
app/models/concerns/foreman/thread_session.rb:148:in `as_location'
app/models/taxonomy.rb:64:in `block in as_taxonomy'
app/models/concerns/foreman/thread_session.rb:113:in `as_org'
app/models/taxonomy.rb:63:in `as_taxonomy'
app/models/taxonomy.rb:57:in `no_taxonomy_scope'
app/controllers/concerns/foreman/controller/taxonomies_controller.rb:65:in `edit'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
Comment 1 Og Maciel 2015-10-02 17:40 EDT
Created attachment 1079536 [details]
stacktrace screenshot
Comment 3 Corey Welton 2015-10-02 17:53:45 EDT
Same UI message occurs in "Manage Organizations" > $org > Edit
Comment 5 Mike McCune 2015-10-05 17:15:15 EDT
This is caused by code that was cherry picked for:

https://bugzilla.redhat.com/show_bug.cgi?id=1207972

I vote we close this one and just FailsQA 1207972
Comment 6 Corey Welton 2015-10-05 17:35:33 EDT
Will close this out once we get a new a new compose with the reverted cherrypick above.
Comment 7 Mike McCune 2015-10-05 17:43:55 EDT
I'd actually keep this one and VERIFY it when we get a new compose
Comment 10 Og Maciel 2015-10-06 11:21:36 EDT
Verified on Satellite-6.1.0-RHEL-6-20151005.1 compose

Preliminary results from our automation also show that this has been fixed.
Comment 11 Bryan Kearney 2015-10-15 14:49:12 EDT
This bug was fixed with Satellite 6.1.3 which was released on 15 October, 2015. The errata for this release are

 https://access.redhat.com/errata/RHBA-2015:1910
 https://access.redhat.com/errata/RHBA-2015:1911

Note You need to log in before you can comment on or make changes to this bug.