Bug 1268489 - logon screen password entry requires multiple attempts before password is accepted
logon screen password entry requires multiple attempts before password is acc...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wayland (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 18:36 EDT by Leslie Satenstein
Modified: 2015-10-20 00:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 00:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2015-10-02 18:36:48 EDT
Description of problem:

However, with Gnome Wayland selected, it takes multiple attempts to have my password accepted for the LOGON SCREEN.

Password entry works ok with regular Gnome interface.

My password format is #montreal001  tryit with #qwert001

Version-Release number of selected component (if applicable):

uname -a
Linux F23SDC 4.2.1-300.fc23.x86_64 #1 SMP Mon Sep 21 22:13:13 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

All Gnome updates as of this posting within Fedora 23 beta-rc1  There is no gnome version information when clicking on the help icon. 



How reproducible:

Since I discovered the problem...

Switch from Gnome to Gnome Wayland and very carefully, click on user icon
when password prompt occurs, very carefully enter the password.



Steps to Reproduce:
1.
2.
3.

Immediately after a boot, or immediately after changing from Gnome to Gnome-Wayland or immediately after logout (while not leaving Gnome Wayland selection) and retrying with Gnome-Wayland.

Actual results:
After a logout, password is definitely rejected at first and immediately main prompt reappears. I repeat the selection of my logon and then very carefully enter the password a second time. 

It can be accepted or rejected. Most of the time second or third attempt is accepted.  

Expected results:

Gnome Wayland presentation of password to be accepted the first time, as it is done with normal non-wayland Gnome 


Additional info:

To be reconfirmed --- 
I tried it once and it really needs further testing, but a backspace char followed by the #password001 format worked first time with Wayland login process.

Does the # as first character have any significance. my passwords have € and ¥ as special characters.

Note 2
Two keyboard layouts used...

US keyboard layout is #2, Canada French is #1   I never switch to US layout between system boots.  
(US layout is kept for other non-admin user(s).  Again, with regular Gnome, this dual keyboard settings has never caused problems.
Comment 1 Leslie Satenstein 2015-10-03 21:34:03 EDT
Backspace as first character has no effect.
I switched to Wayland for Fedora 22, (Actually was using Wayland in F22), and the logon problem is not present.

The logon problem is a Wayland Fedora 23 problem.
Comment 2 Leslie Satenstein 2015-10-04 11:08:05 EDT
Tested and not fixed with update to...

Linux F23SDC 4.2.2-300.fc23.x86_64 #1 SMP Wed Sep 30 01:36:26 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Leslie Satenstein 2015-10-20 00:40:02 EDT
This feature works with TC11 update 

Linux F23SDC 4.2.3-300.fc23.x86_64 #1 SMP Mon Oct 5 15:42:54 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.