Bug 1268494 - nco-4.4.4-1.el7 is not linked with current versions of other packages like hdf5 and libcurl
Summary: nco-4.4.4-1.el7 is not linked with current versions of other packages like hd...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nco   
(Show other bugs)
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-02 23:06 UTC by stevecousins
Modified: 2015-10-05 19:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 19:06:26 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stevecousins 2015-10-02 23:06:05 UTC
Description of problem:

The nco package is built with versions of other libraries that are no longer in EPEL. For instance running the ncks program produces an error stating that it cannot find libhdf5_hl.so.7. This is because the hdf5 package includes libhdf5_hl.so.8 instead. Similar with libcurl.so.3 instead of libcurl.so.4.

I created links to correct this but still there is a problem:

   ncks: symbol lookup error: /lib64/libnco-4.4.4.so: undefined symbol: nc_inq_format_extended



Version-Release number of selected component (if applicable):

4.4.4-1.el7

How reproducible:
very

Steps to Reproduce:
1. yum install nco
2. extract a var from a netcdf file:

   ncks -O -v time my_file.nc test.nc


Actual results:

   ncks: error while loading shared libraries: libhdf5_hl.so.7: cannot open shared object file: No such file or directory 

Expected results:

   file test.nc would be created with the time variable in it

Additional info:

Comment 1 Orion Poplawski 2015-10-03 01:49:32 UTC
I can't reproduce this.  My nco is linked with the proper hdf5 library:

# ldd /usr/lib64/libnco-4.4.4.so | grep hdf
        libhdf5_hl.so.8 => /lib64/libhdf5_hl.so.8 (0x00007f2ee3a0d000)
        libhdf5.so.8 => /lib64/libhdf5.so.8 (0x00007f2ee3412000)

What is the output of:

yum list nco
rpm -Va nco
rpm -qi nco

Comment 2 stevecousins 2015-10-05 18:59:38 UTC
Sorry for the noise. It looks like LD_LIBRARY_PATH was getting in the way that contained a netcdf libraries with the version 7 HDF libraries. Again, apologies. I should have found this.

Thanks for your help.


Note You need to log in before you can comment on or make changes to this bug.