Bug 1268505 - Licensing issue in src/FSAL/FSAL_PT/fsal_attrs.c
Licensing issue in src/FSAL/FSAL_PT/fsal_attrs.c
Status: CLOSED NEXTRELEASE
Product: nfs-ganesha
Classification: Community
Component: FSAL (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Frank Filz
: Reopened
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2015-10-02 19:56 EDT by Michael Scherer
Modified: 2015-10-09 14:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 14:07:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2015-10-02 19:56:26 EDT
It seems that package ship non free code, so should be removed:

https://github.com/nfs-ganesha/nfs-ganesha/issues/69
Comment 1 Kaleb KEITHLEY 2015-10-05 12:48:53 EDT
The FSAL_PT is not built for Fedora, EPEL, or anything else.

Our resident license attorney has told me that if files with inappropriate (for Fedora) licenses aren't built into what we ship, e.g. .../os/freebsd/*, .../FSAL/FSAL_PT/*, then we (we being Red Hat, Fedora, CentOS) don't have anything to be concerned about.

If there are files that you have concerns about then feel free to open bugzillas for them at https://bugzilla.redhat.com/enter_bug.cgi?product=nfs-ganesha. You might also run it by us on the nfs-ganesha-devel mailing list at nfs-ganesha-devel@lists.sourceforge.net or in #ganesha on freenode.
Comment 2 Tom "spot" Callaway 2015-10-06 09:32:13 EDT
We still distribute the source rpm, and since the license on that file only says "All Rights Reserved", we do not have permission to redistribute it (technically, neither does the Ganesha upstream).

Please just make a clean source tarball that does not include that file.
Comment 3 Richard Fontana 2015-10-06 13:52:40 EDT
Since I believe I was the resident license attorney in this case, I just wanted to clarify: We still need royalty-free permission to copy and distribute such non-built source files. 

It's not obvious to me that we don't have such permission here, though. I wouldn't conclude otherwise merely because "All rights reserved" is in the legal notice and merely because there is no license notice there.
Comment 4 Tom "spot" Callaway 2015-10-07 05:56:37 EDT
While I agree with Richard that it is likely that there is a license on this file, there is no clear indication that I have been able to find as to what that license is. The logical next step to resolve this upstream is to ask IBM to confirm the license terms on that file.

My proposal to remove the file from the source tarball was to resolve the issue in the short term for Fedora.
Comment 5 Kaleb KEITHLEY 2015-10-09 14:07:13 EDT
license is fixed in rc6.

Note You need to log in before you can comment on or make changes to this bug.